Owncloud login page is broken

Steps to reproduce

  1. Install ownCloud
  2. set it up
  3. try to login

Expected behavior

Working log-in screen should appear

Actual behavior

Log-in screen is broken, see the screenshot:

Logs and config

Those are located at

Server configuration

Operating system: openSUSE Leap 15.1 on Raspberry Pi 3

Web server: Apache/2.4.33 (Linux/SUSE)

Database: MySQL 10.2.25-MariaDB SUSE package

PHP version: PHP 7.2.5
ownCloud version:

Updated from an older ownCloud or fresh install: fresh install

Where did you install ownCloud from: https://download.owncloud.org/download/repositories/production/openSUSE_Leap_15.1/

Signing status (ownCloud 9.0 and above):

Login as admin user into your ownCloud and access 
paste the results into https://gist.github.com/ and puth the link here.

-> Impossible, cannot login

The content of config/config.php:

See Github gist

List of activated apps:
See Github gist

Are you using external storage, if yes which one: no

Are you using encryption: no

Are you using an external user-backend, if yes which one: no

Client configuration

Browser: Firefox 68.1.0esr

Operating system: openSUSE Leap 15.1


Web server error log

See Github gist

ownCloud log (data/owncloud.log)


Browser log

See Github gist

Anything else

I also tried to download ownCloud as .zip and extract it, but same

Can you be more specific? What guide did you follow what packages did you install?

1 Like

Alright, here it is. I fired up:

$ rpm --import https://download.owncloud.org/download/repositories/production/openSUSE_Leap_15.1/repodata/repomd.xml.key
$ zypper addrepo http://download.owncloud.org/download/repositories/production/openSUSE_Leap_15.1/ce:stable.repo
$ zypper refresh
$ zypper install owncloud-files

This creates a folder named ‘owncloud’ at /srv/www/htdocs/owncloud.
It contains the same files as the zip file provided at https://owncloud.org/download/.

Before doing this, I already had apache2 and php7 installed.

Then I used the setup wizard for setting everything up.

please check the php packages and apache packages that you installed with the ones recommended in our official docs.

1 Like

Alright, fixed it. I reinstalled the OS and then it worked.

1 Like