Owncloud 10.2.1 invalid email address error

Steps to reproduce

  1. Issue is presistant

Expected behaviour

Initial setup of owncloud 10.2.1 with PHP7.2.17, setup was fine and busy setup e-mail server under Admin, General. And this is where the problem occur.

Actual behaviour

It constantly give me the error ‘Invalid email address’, even if I throw in something as simple as user@live.com

Server configuration

Operating system: Entware

Web server: lighthttpd

Database: SQLite

PHP version: 7.2.17

ownCloud version: (see ownCloud admin page) 10.2.1

Updated from an older ownCloud or fresh install: fresh

Where did you install ownCloud from: tar.bz

Signing status (ownCloud 9.0 and above): yes

Login as admin user into your ownCloud and access 
paste the results into https://gist.github.com/ and puth the link here.

The content of config/config.php:

Log in to the web-UI with an administrator account and click on
'admin' -> 'Generate Config Report' -> 'Download ownCloud config report'
This report includes the config.php settings, the list of activated apps
and other details in a well sanitized form.


If you have access to your command line run e.g.:
sudo -u www-data php occ config:list system
from within your ownCloud installation folder

*ATTENTION:* Do not post your config.php file in public as is. Please use one of the above
methods whenever possible. Both, the generated reports from the web-ui and from occ config:list
consistently remove sensitive data. You still may want to review the report before sending.
If done manually then it is critical for your own privacy to dilligently
remove *all* host names, passwords, usernames, salts and other credentials before posting.
You should assume that attackers find such information and will use them against your systems.

List of activated apps:

  - comments: 0.3.0
  - configreport: 0.2.0
  - dav: 0.4.0
  - federatedfilesharing: 0.4.0
  - federation: 0.1.0
  - files: 1.5.2
  - files_external: 0.7.1
  - files_sharing: 0.11.0
  - files_trashbin: 0.9.1
  - files_versions: 1.3.0
  - firstrunwizard: 1.2.0
  - market: 0.5.0
  - notifications: 0.5.0
  - provisioning_api: 0.5.0
  - systemtags: 0.3.0
  - updatenotification: 0.2.1
  - encryption
  - external
  - files_videoplayer
  - user_external

Are you using external storage, if yes which one: local/smb/sftp/… No

Are you using encryption: yes/no No

Are you using an external user-backend, if yes which one: LDAP/ActiveDirectory/Webdav/… No

LDAP configuration (delete this part if not used)

With access to your command line run e.g.:
sudo -u www-data php occ ldap:show-config
from within your ownCloud installation folder

Without access to your command line download the data/owncloud.db to your local
computer or access your SQL server remotely and run the select query:
SELECT * FROM `oc_appconfig` WHERE `appid` = 'user_ldap';

Eventually replace sensitive data as the name/IP-address of your LDAP server or groups.

Client configuration

Browser: Chrome/IE

Operating system:


Web server error log

Insert your webserver log here

ownCloud log (data/owncloud.log)

Insert your ownCloud log here

Browser log

Insert your browser log here, this could for example include:

a) The javascript console log
b) The network log 
c) ...


this doesn’t look right to me. Maybe you can notify the ownCloud developers about this at https://github.com/owncloud/core/issues ?

Can you try with apache and mod_php?
I would assume that you might be missing some PHP libraries, can you double check that?

Done. https://github.com/owncloud/core/issues/36223

1 Like

Below are the package I’ve installed I should have all library covered, unfortunately Apache is too heavy for embedded devices.

php7-cgi \
php7-cli \
lighttpd-mod-fastcgi \
lighttpd-mod-access \
lighttpd-mod-expire \
lighttpd-mod-setenv \
php7-mod-ctype \
php7-mod-curl \
php7-mod-dom \
php7-mod-fileinfo \
php7-mod-gd \
php7-mod-hash \
php7-mod-iconv \
php7-mod-json \
php7-mod-mbstring \
php7-mod-pcntl \
php7-mod-pdo \
php7-mod-pdo-sqlite \
php7-mod-session \
php7-mod-simplexml \
php7-mod-sqlite3 \
php7-mod-xml \
php7-mod-xmlwriter \
php7-mod-xmlreader \
php7-mod-openssl \
php7-mod-intl \

Out of curiosity: Did you try to click on the button Send email anyway? Here the error disappears as soon the cursor/focus leaves the input fields. A quick notice “Saved” appears instead.

The email parts are written to the config.php file.

'mail_domain' => 'live.com',
'mail_from_address' => 'user',
'mail_smtpmode' => 'php',
1 Like

Don’t think it would work, but out of ‘why the heck not’, yep not working. I guess I can write in to the config.php manually. Do you have the template if I shall use SMTP instead?



there you go:

  'mail_smtpmode' => 'smtp',
  'mail_smtphost' => 'yourhost,
  'mail_smtpport' => '25',
  'mail_domain' => 'live.com',
  'mail_from_address' => 'user',

More information here.

Following your link, I’ve added the relevant info to config.php

  'mail_domain' => 'host.com',
  'mail_from_address' => 'user',
  'mail_smtpmode' => 'smtp',
  'mail_smtphost' => 'smtp.server.com',
  'mail_smtpport' => 587,
  'mail_smtpsecure' => 'tls',
  'mail_smtpauth' => true,
  'mail_smtpauthtype' => 'LOGIN',
  'mail_smtpname' => 'me',
  'mail_smtppassword' => 'password',               

When I tried to send a test mail, it prompt me to set my e-mail address, which gave me the same error message:

So I went around under the User field, thankfully it allowed me to force the e-mail field there. (Didn’t want to have to start manually edit the database again) But when I try to send test e-mail, throw me this error:

In the end, still can’t get away…


thanks for your answer, that’s very odd, what was the email address look ? Still something like user@live.com ? You can try out your email address here but I wouldn’t type the real one.
Nevertheless at this point I’d suggest you open an issue.

EDIT: I see you already opened one.

1 Like

Yes, really simple e-mail address with no special characters…

Despite I’ve opened the ticket on Github, there isn’t any response yet. Finger-crossed.

1 Like