Owncloud 10.6.0 cifs/smb share

Steps to reproduce

  1. Existing 10.6.0 owncloud instance with external cifs/smb storage (settings-admin-storage)
  2. Assign storage to admin group and login with an admin user
  3. Share a folder inside this one with user test.
  4. Add a new file / folder in the shared folder with test directly on the SMB share.
  5. Refresh the page, the files all show and are readable, except the new file / folder.
  6. Login with the admin account. go to the folder, now I see the file / folder
  7. Without doing anything else the files now also show up under the user test.

Extra info

Manually scanning with the following command:
occ files:scan admin --path="/admin/files/FOLDER/FOLDER

Makes the files show up for the test user without logging into the admin account

Expected behaviour

Show the new files /folders when ONLY the user test is logged in.

Actual behaviour

The files are only showing when the person who shares them logs in and opens that specific folder. Then the test user can suddenly also see them.

Server configuration

Operating system:
Ubuntu 20.04 fully updated.

Web server:

Mysql MariaDB

PHP version:

ownCloud version: (see ownCloud admin page)
10.6.0 latest docker image.

Updated from an older ownCloud or fresh install:
Tried with a new install and a copy from the old install.

Where did you install ownCloud from:

Signing status (ownCloud 9.0 and above):

There might be a problem with the share, although there might be a reason why the share isn’t able to check for changes in the underlying storage.

For the time being, you can assume that the admin (in your case) needs to check the files first before being available to the sharees.

1 Like

Yeah, but this does feel like a bug in owncloud right?
I have the exact same problem with a brand new SMB3 linux share and a brand new owncloud installation.

The files are managed through another third party application and put on the share remotely, without interaction through owncloud. Having the administrator login each time is a complete waste of time because he coulve just added 20 new files in 20 different subdirectories.

Any idea how we could bypass this bug or if a fix might be on the way?

You’ll need to let the users access directly to the storage, not through an ownCloud share.

In the mount point configuration (settings page > storage) you can set up who will be able to access to the mount point (the “available for” column). Normally, this is empty, meaning that any logged in user can access to that mount point.
For the authentication, you can use the “username and password” auth if you want that all the users use the same credentials, or “login credentials” if you want the users to access to the smb storage using their ownCloud credentials.

1 Like

I think I found a better solution.

We could mount all the shares inside the admin user on the system where the files get uploaded to the share directly and use webdav instead of SMB. I just did a small test and it seems that this works!

1 Like