OwnCloud 10 blank page after upgrade from 9


#1

Steps to reproduce

After upgrading from 9 to 10, loading localhost/owncloud, getting a blank page

Expected behaviour

Tell us what should happen

Actual behaviour

Tell us what happens instead

Server configuration

Operating system: Ubuntu 18.4

Web server:
Apache 2.4.29

Database:
MySQL 5.0.12

PHP version:
7.2.10

ownCloud version: (see ownCloud admin page)
10

Updated from an older ownCloud or fresh install:
Update from 9

Where did you install ownCloud from:
http://download.owncloud.org/download/repositories/production/Ubuntu_18.04/

Signing status (ownCloud 9.0 and above):

Login as admin user into your ownCloud and access 
http://example.com/index.php/settings/integrity/failed 
paste the results into https://gist.github.com/ and puth the link here.

I can't log into ownCloud

The content of config/config.php:

<?php $CONFIG = array ( 'updatechecker' => false, 'instanceid' => 'ocd0jxx7gpk9', 'passwordsalt' => [HIDDEN] 'secret' => [HIDDEN] 'trusted_domains' => array ( 0 => 'localhost', 1 => [HIDDEN] ), 'datadirectory' => '/mnt/hgfs/[HIDDEN]', 'overwrite.cli.url' => 'http://localhost/owncloud', 'dbtype' => 'mysql', 'version' => '9.1.4.2', 'dbname' => [HIDDEN] 'dbhost' => 'localhost', 'dbtableprefix' => 'oc_', 'dbuser' => [HIDDEN] 'dbpassword' => [HIDDEN] 'logtimezone' => 'UTC', 'installed' => true, 'mail_from_address' => [HIDDEN] 'mail_smtpmode' => 'smtp', 'mail_domain' => [HIDDEN] 'mail_smtpauthtype' => 'LOGIN', 'mail_smtphost' => [HIDDEN] 'mail_smtpport' => '25', 'memcache.local' => '\\OC\\Memcache\\APCu', 'mail_smtpauth' => 1, 'appstore.experimental.enabled' => true, 'mail_smtpname' => [HIDDEN] 'mail_smtppassword' => '[HIDDEN] 'log_type' => 'owncloud', 'logfile' => '/var/log/owncloud.log', 'loglevel' => 0, 'syslog_tag' => 'ownCloud', 'logdateformat' => 'F d, Y H:i:s', 'logtimezone' => 'Europe/London', 'log_query' => true, 'debug' ⇒ true, ); ``` Log in to the web-UI with an administrator account and click on 'admin' -> 'Generate Config Report' -> 'Download ownCloud config report' This report includes the config.php settings, the list of activated apps and other details in a well sanitized form. or If you have access to your command line run e.g.: sudo -u www-data php occ config:list system from within your ownCloud installation folder *ATTENTION:* Do not post your config.php file in public as is. Please use one of the above methods whenever possible. Both, the generated reports from the web-ui and from occ config:list consistently remove sensitive data. You still may want to review the report before sending. If done manually then it is critical for your own privacy to dilligently remove *all* host names, passwords, usernames, salts and other credentials before posting. You should assume that attackers find such information and will use them against your systems. ``` **List of activated apps:** ``` If you have access to your command line run e.g.: sudo -u www-data php occ app:list from within your ownCloud installation folder. When I run this command, I get 'Could not open input file: occ' ``` **Are you using external storage, if yes which one:** local/smb/sftp/... no **Are you using encryption:** yes/no not sure **Are you using an external user-backend, if yes which one:** LDAP/ActiveDirectory/Webdav/... no ### Client configuration **Browser:** **Operating system:** ### Logs #### Web server error log ``` [Sun Jan 27 22:03:58.874870 2019] [ssl:warn] [pid 1015] AH01909: 192.168.1.58:10:0 server certificate does NOT include an ID which matches the server name [Sun Jan 27 22:03:58.875776 2019] [mpm_prefork:notice] [pid 1015] AH00163: Apache/2.4.29 (Ubuntu) OpenSSL/1.1.0g configured -- resuming normal operations [Sun Jan 27 22:03:58.875804 2019] [core:notice] [pid 1015] AH00094: Command line: '/usr/sbin/apache2' [Sun Jan 27 22:03:58.885127 2019] [:error] [pid 3042] avahi_entry_group_add_service_strlst("resubuntu") failed: Local name collision [Sun Jan 27 22:17:40.096968 2019] [php7:warn] [pid 3044] [client 127.0.0.1:36878] PHP Warning: fopen(/var/www/owncloud/config/config.php): failed to open stream: Permission denied in /var/www/owncloud/lib/private/Config.php on line 251 [Sun Jan 27 22:17:40.097125 2019] [php7:warn] [pid 3044] [client 127.0.0.1:36878] PHP Warning: flock() expects parameter 1 to be resource, boolean given in /var/www/owncloud/lib/private/Config.php on line 261 [Sun Jan 27 22:17:40.097218 2019] [php7:error] [pid 3044] [client 127.0.0.1:36878] PHP Fatal error: Uncaught Error: Call to a member function getLogger() on null in /var/www/owncloud/index.php:72\nStack trace:\n#0 {main}\n thrown in /var/www/owncloud/index.php on line 72 ``` #### ownCloud log (data/owncloud.log) ``` 1 [The log file just contains this] ``` #### Browser log ``` Insert your browser log here, this could for example include: a) The javascript console log b) The network log c) ... ```

#2

Hey,

could it be possible that you have missed to provide most of the required information like the question of log files, how you did the upgrade and similar?


#3

Hi there, thanks for getting back to me. I couldn’t figure out how to get hold of the log files without logging into ownCloud. Can you point me in the right direction with what I need to provide and how I get hold of it please?

The upgrade was done by downloading the file in the link provided, which then took me to the Ubuntu installer. I ran the installer.

I’ve actually tried this upgrade several times without success. I’ve tried installing from the Tarball and I’ve tried running the shell commands listed here: https://download.owncloud.org/download/repositories/stable/owncloud/index.html

With both I always run into error messages of some sort, the only one that seems to work is downloading this: http://download.owncloud.org/download/repositories/production/Ubuntu_18.04/all/
which then launches the Installer.

Thanks


#4

Hey,

i think the most important log files are the ones mentioned here:

It seems the documentation has some notes about both which could help you to identify these:

https://doc.owncloud.org/server/administration_manual/issues/general_troubleshooting.html


#5

Great, thank you. Have updated the details above. The OC log file just contains ‘1’ though, nothing else…


#6

Permission denied in /var/www/owncloud/lib/private/Config.php on line 251

At a first glance I see the permissions for the ownCloud installations are not set correctly. For Ubuntu you can fix this with

sudo chown -R www-data:www-data /var/www/owncloud

from the shell. Then I’d recommend to run the upgrade again:

cd /var/www/owncloud
sudo -u www-data php occ upgrade

Does this fix your issue?


#7

Ok, this looks more promising but I’ve hit another issue. I had to install some missing PHP modules to get this going (ZIP, cURL and intl) but now I’m getting this:


January 28, 2019 11:10:58 Repair warning: You have incompatible or missing apps enabled that could not be found or updated via the marketplace.
January 28, 2019 11:10:58 Repair warning: Please install or update the following apps manually or disable them with:
occ app:disable logreader
occ app:disable passwordpolicy
January 28, 2019 11:10:58 Repair warning: For manually updating, see https://doc.owncloud.org/server/10.0/go.php?to=admin-marketplace-apps
January 28, 2019 11:10:58 OC\RepairException: Upgrade is not possible
January 28, 2019 11:10:58 Update failed
January 28, 2019 11:10:58 Maintenance mode is kept active
January 28, 2019 11:10:58 Reset log level


I’ve tried running the command ‘occ app:disable logreader’ but I get: “Command ‘occ’ not found”


#8

I’m glad you made it this far. occ ist best called from within the ownCloud installation directory. So change to it with

cd /var/www/owncloud

every time you want to use occ. Then you may disable the mentioned apps with

sudo -u www-data php occ app:disable logreader

and the same for passwordpolicy. Then run the upgrade again.

I’m afraid the logreader is not available any more (does anybody know more about this?), but after the upgrade you can re-install the Password Policy app directly from the Marketplace with

sudo -u www-data php occ market:install password_policy

HTH


#9

Thanks so much for all your help guys, I feel like I’m getting closer… but still no cigar.

I did as you advised and this time it seemed to run the upgrade to the end. I then re-installed the password policy and restarted Apache.

But when I go to localhost/owncloud I get: ‘Not Found. The requested URL /owncloud/index.php/login was not found on this server. Apache/2.4.29 (Ubuntu) Server at localhost Port 80’


#10

This looks like an issue with the apache configuration. Does the configuration as cited in the docs
https://doc.owncloud.org/server/10.0/admin_manual/installation/source_installation.html#apache-configuration-label work for you?


#11

Amazing, this worked! Thank you so much, you guys rock!