Owncloud 10 - External Sorage Local doesn't work

external_storage

#1

Hello
I have some issues with the local external storage on my Owncloud 10.0.4
I have seen some similar problems here ( https://github.com/owncloud/core/pull/27590) and my problem seem to look similar but the workaround there doesn't work for me. I have also problems adding new local storage folders, but at my config.php file, don't have the possibility to change the "files_external_allow_create_new_local" to "true", because this is not listed there.

I have already mounted a external storage on my Owncloud (to this time 9.XX) and this folder still appears. At the external storage option the indications light is on green, but when i try to enter the folder, it redirects me to the main data menu.

Expected behavior

Opening external data folder on a local hard drive

Actual behavior

showing green light at the external storage settings
re direkting to the main folder after opening the external folder

Server configuration

Operating system:
MacOS 10.13
Web server:
mac server

ownCloud version:
10.0.4.4

Updated from an older ownCloud or fresh install:
I did a fresh install when updating to the current version

As you probably see by now, I am not a trained IT, so please understand when some informations are missing or I don't get some things right at the first time.

Thank you for your help

Kilian


#2

Hi, you have to add this line to the config.php file, it's not there per default.


#3

Ok,
Is it important to add it in a special place?
Because I tried this and my whole cloud wasn’t working then. I had to take the config.php out of an backup to make the ownCloud run again


#4

You config.php ends usualy with a closed braket, right? like this:

);

so just insert the line like this:

'files_external_allow_create_new_local' => true,

before that, and after the previous line ends with a comma.


#5

Thank you dmitry

I tried you advice but it didn't work.
This is my original config.php ...

...and when I put the 'files_external_allow_create_new_local' => true, in like this...

...the cloud doesn't work anymore
Probably I am too stupid to do it right. So please be patient with me and explain me what I am doing wrong here

Thanks in advance


#6

Okay, if you remove that line you cloud works normal, right?

can you copy paste the entries from you config php, removing the sensible information but leaving the commas and single quotes in? I can't see from your screen shot where the mistake is.


#7

Sure
Thank you for your help!!

When I remove it the cloud works but it takes some time. But when I just use my backup it works right away.


#8

Question, why do you have your log level set to 0?

I suppose for debugging purposes. Do you see any errors?


#9

to be honest
I have no idea
I just did some modification at the trusted domains but other than that I didn't do any modification


#10

Can you generate a config report?


#12

config_report_20180119.txt (87.0 KB)

Sorry
I had to remove the hostname and I replaced it like before with XXX

Thank you very very much for your help


#13

Can you check your log file for errors?

Also can you tell me something about your setup?
Your errors sounds very strange


#14

I run the own cloud on a Mac mini and over the macserver app

yes I will take a look but this can take some time
any advice of what kind of error I should search?


#15

Not really, just errors. Anything you find would give us a clue


#16

There where no errors in the Log file


#17

can you post some lines of the apache log or the apache error log?


#19

Problem solved.

Thank you very much dmitry. I had to use the terminal and not the TextEdit Programm. So to be honest. I were to stupid to put in one line properly

But thank you very much


#20

No Problem :slight_smile:

Glad that you worked out the errors by yourself.

In my opinion it's always a great feeling to fix something that did not work before :slight_smile: