Owncloud 8 installation with redis

81x-eol
webserver_issue

#1

Steps to reproduce

First of all: sorry for my english and probably sorry for my explanation. I am newbie in
Owncloud.

I made a clean installation of owncloud on debian wheezy according to this howto:
https://www.robert-sperling.de/owncloud-performance-tuning-fuer-owncloud-8-x/

I know, the howto is written for Jessie, but all steps works. So there is php 5.4.45,
apache 2.2.22, mysql Ver 14.14 and Owncloud 8.1.9.2 installed.
Now I would like to enable redis memcache in order to get a better performance. Therefore I
tried the following howto:

https://www.bdjl.de/localhost/?p=4681

Expected behaviour
I would like to get faster access to owncloud especially for external access and by viewing photos.

Actual behaviour
But after adding the redis lines in config.php of owncloud, I only get a white page.

Server configuration
Operating system: debian wheezy
Web server: apache2
Database: mysql Ver 14.14
PHP version: 5.4.45
ownCloud version (see ownCloud admin page): 8.1.9.2

My /var/www/owncloud/config/config.php:

<?php

define('DEBUG',true);

$CONFIG = array (

'instanceid' => 'ocdfdf',

'passwordsalt' => 'xxx/xxxxxxxxxxxxxxxxxx',

'secret' => 'xxxxxxxxxxxxxxxxxxxxx',

'trusted_domains' =>

array (

0 => '192.168.200.22',

),

'datadirectory' => '/var/www/owncloud/data',

'overwrite.cli.url' => 'http://192.168.200.22/owncloud',

'dbtype' => 'mysql',

'version' => '8.1.9.2',

'dbname' => 'owncloud',

'dbhost' => 'localhost',

'dbtableprefix' => 'oc_',

'dbuser' => 'owncloud',

'dbpassword' => 'xxx',

'logtimezone' => 'UTC',

'installed' => true,

'memcache.local' => '\OC\Memcache\Redis',

'filelocking.enabled' => 'true',

'memcache.distributed' =>'\OC\Memcache\Redis',

'memcache.locking' => '\OC\Memcache\Redis',

'redis' =>
array (

  'host' => 'localhost',

  'port' => 6379,

  'timeout' => 0,

  'dbindex' => 0,

 ),

);

/var/log/redis/redis-server.log

[3327] 25
Sep 14:27:14 # User requested shutdown...

[3327] 25 Sep 14:27:14 * Saving the final RDB snapshot before exiting.

[3327] 25 Sep 14:27:14 * DB saved on disk

[3327] 25 Sep 14:27:14 * Removing the pid file.

[3327] 25 Sep 14:27:14 # Redis is now ready to exit, bye bye...

[3389] 25 Sep 14:27:15 * Server started, Redis version 2.4.14

[3389] 25 Sep 14:27:15 * DB loaded from disk: 0 seconds

[3389] 25 Sep 14:27:15 * The server is now ready to accept connections on port 6379

/var/log/apache2/error.log

[Sun Sep 25 07:25:27 2016] [error] [client 192.168.200.34] PHP Fatal error: Uncaught OC\HintException: [0]: Missing
memcache class \OC\Memcache\Redis for local cache (Is the matching PHP
module installed and enabled ?)\n\n
thrown in /var/www/owncloud/lib/private/memcache/factory.php on line 75

[Sun Sep 25 07:27:04 2016] [notice] caught SIGTERM, shutting down

PHP Warning: PHP Startup: Unable to load
dynamic library '/usr/lib/php5/20100525/redis.so' -
/usr/lib/php5/20100525/redis.so: cannot open shared object file: No such file
or directory in Unknown on line 0

[Sun Sep 25 07:27:05 2016] [notice] Apache/2.2.22 (Debian) PHP/5.4.45-0+deb7u5
mod_ssl/2.2.22 OpenSSL/1.0.1e configured -- resuming normal operations

[Sun Sep 25 14:28:09 2016] [error] [client 192.168.200.34] PHP Fatal error: Uncaught OC\HintException: [0]: Missing
memcache class \OC\Memcache\Redis for local cache (Is the matching PHP
module installed and enabled ?)\n\n
thrown in /var/www/owncloud/lib/private/memcache/factory.php on line 75

I think, in apache error.log, the error is described, but unfortunately I don’t know, what
I should change.

If there are other logs or other debug level, that I should enable, please let me know.
My owncloud log is empty.

Shall I upgrade to oc 9 ? This is just a test installation. I am using an other owncloud installation, but the access of my other owncloud is too slow. As I wasn't able to enable redis there, I tried a clean installation. But with the same result: a white page...

Thanks and best regards
Kamikaze


#2

Hi,

upgrading ownCloud won't solve this issue as is it caused by a missing / wrong configured PHP environment and not by ownCloud.

You need to somehow manage to get this error here fixed and the PHP redis module correctly loaded:

/usr/lib/php5/20100525/redis.so: cannot open shared object file: No such file
or directory in Unknown on line 0

To get support for this task you might want to get in touch with a community like:

http://forums.debian.net/

where you can reach more experts familiar with your used linux distro.


#3

Any reason that you still use debian wheezy? Jessie brings everything in the right version. Installing through external sources makes everything more complicated (installing, configuration and also to keep your system updated).


#4

I installed debian in a vm on xenserver 6.5, there is a template for squeeze and wheezy. No other reason. But then I'll try first an installation with jessie.


#5

Well... I installed Jessie, add no further repository, install just owncloud, mysql and redis and after adding the lines in config.php of owncloud I still can access my owncloud website. I cannot believe it at present:-) I have to read some logs, in order to check, whether it really works;-)

But it is just owncloud 7, and php 5. I don't know whether it is maybe recommendend to upgrade to owncloud 8 or 9 and php to php 7 ? Can anybody give me a hint ?


#6

Please don't use ownCloud 7 from Debian directly. Thats a too outdated and also unsupported version. Instead make a fresh installation of ownCloud 9.1.1 from the repositories provided at owncloud.org.


#7

Thanks a lot, I'll search for the repositories. and which php Version would you prefer ? I saw a lot of howtos with php7 but I don't know whether it better works with owncloud.


#8

You can freely choose: PHP 5.6 means that you don't need 3rdparty repositories like dotdeb.org, PHP 7.0.x needs 3rdparty repositories. PHP 5.6 is more stable, PHP 7.0.x is a lot faster.


#9

Well, I installed OC 9.1.1.3 from repository, redis 2.8.17, php5.6.24 (I prefer stable version than faster as soon as it is possible for work) and mysql-server 5.5.52.
Owncloud works with redis, but it is still slow in my opinion.
I'm testing with different option in config.php.
How does this forum works - shall I open another topic ? The topic with owncloud 8 doesn't match my actual problems;-) Cpu is very high and it seems, that the server needs a lot of time to make preview of pictures (my first tests are with photos).


#10

I woud say: Create a new topic, if this topic is resolved.


#11

Yes, always a new thread for each question: