Owncloud 9.1.1 - Difficulty to access Windows Server 2012 R2 Shared Folder (via CIFS/SMB External Storage) with LDAP authentication

smb
external_storage
ldap
9.1.x
help

#1

On my Windows Server 2012 R2 Files Server, I created a share named "Ventes" on E:\Ventes.
On my OwnCloud, I configured an external storage with OC Credentials (LDAP MS AD 2012R2). I entered IP of files server (10.33.10.26), share name (Ventes), domain name (micrologic2010) and it's displayed a red square.

The only way that I found to make this working is to create a share directly on drive E and enter an "Remote Subfolder" pointing on folder Ventes. With this way, I can access the folder Ventes and all is working.

I test with my older files server (windows server 2008 R2) and I don't have this problem.

Server configuration
Operating system:Ubuntu 16.04.1 LTS
Web server:Apache 2.4.18
Database:MySQL 5.7.15
PHP version:7.0.8
ownCloud version (see ownCloud admin page):9.1.1
Updated from an older ownCloud or fresh install:fresh
Screenshot of the external storage config : https://drive.google.com/file/d/0B0F9rbBh9vCUQ01oTG9zeGRRbXc/view?usp=sharing
OwnCloud Logs file : https://drive.google.com/file/d/0B0F9rbBh9vCUZ1ZmRzRvQjd4cm8/view?usp=sharing
Integrity status for oC9+

No errors have been found.

#2

Hi there, did you manage to solve this issue?
I have exactly the same problem.

Thanks


#3

Hi pporto,

I tried many things to solve the issue and my final hypothesis is my domain.

  1. I tried with brand new AD domain with brand new Windows Server 2012 R2 server (file server) and brand new Ubuntu 16.04 server that host OwnCloud and no problem.

  2. I tried, with this new setup, install all Windows updates and all Ubuntu updates. Still working.

  3. I created all OU, Groups and Users in this new domain... Still working.

  4. I'm about to create all same GPO in new domain.... After half created, still working.