(ownCloud 9.1.3) All Share Links Asking For HTTP Authentication?

cpanel
9.1.x
help

#1

Hi guys,

I am working on a new ownCloud server, it's running on a CentOS server with cPanel, under one of the cPanel user accounts.

I seem to be encountering an issue where every share link prompts for a password (through a prompt that looks like it's coming from a .htaccess.htpasswd authentication, not the ownCloud shared folder login screen).

This seems to be an issue others are encountering but I am unclear on what they're doing to fix it, it sounds like a code issue but we are running 9.1.3 latest. Here are a few other related threads:
https://forum.owncloud.org/viewtopic.php?t=30771

I also went through this section of the documentation, on required Apache modules, and confirmed that I have all recommended Apache modules installed:
https://doc.owncloud.org/server/9.1/admin_manual/installation/source_installation.html#additional-apache-configurations

Any suggestions as to how I may be able to resolve this would be greatly appreciated!


#2

Try to disable all 3rdparty apps (like e.g. Gallery+)


#3

Didn't work. I disabled all apps. Then I enabled only:

Share Files 0.10.0
by Michael Gapczynski, Bjoern Schiessle (AGPL-licensed)

Since we need this app to Share files. And we're getting the same error.


#4

Then most likely some strange webserver configuration is messing around here.


#5

We've checked everything we could think of on the server. If any one has any thoughts, please share...


#6

Hi, is there some information in the server logs, did you change something in the htaccess?


#7

Those were the first two places we checked:

a) nothing in error logs

b) we even renamed .htaccess file and put a blank one


#8

are you running mod_php? Is the Virtualhost-config the same as in the documentation (possible in cPanel?):
https://doc.owncloud.org/server/latest/admin_manual/installation/source_installation.html?highlight=apache#apache-configuration-label