Owncloud 9.1.5 - files / database inconsistent


#1

Hi,
one user reported the following problem: He created a folder, shared the folder and added some pdf documents.
Now he tried to delete some files. The files seems to begone, but after a refresh of the browser the files are shown again!
I looked into the file store - the folder is empty. So the files are already deleted (physically) but seems to exist in the database. How can we repair this situation ? How can I check the database for inconsistent between DB <-> files ?

We tried to remove the sharing.
We did a
sudo -u www-data php occ files:scan USERNAME
sudo -u www-data php occ files:cleanup USERNAME

Bye, Peer


#2

Hi, what is the output of those commands?


#3

Nothing - it runs and everything seems to be fine. No error message:

root@oc:/var/www/owncloud# sudo -u www-data php occ files:scan USER
Starting scan for user 1 out of 1 (USER)

+---------+-------+--------------+
| Folders | Files | Elapsed time |
+---------+-------+--------------+
| 533 | 4182 | 00:00:05 |
+---------+-------+--------------+


#4

Hi,
we checked it once again. All occ comands arer showing NO error for the user.

The folder is shared and has 3 pdf files inside. Trying to open the pdf gives an error message (files are deleted on the file system). If I restore the files (backup), we can open all three pdfs.
When we select one pdf and delete the file it is gone (in the web gui and on the file system!), but reappears after the next refresh( but not at the file system level!).

The owncloud log only shows an error, when we try to open the physically already deleted file.

So why can we delete the file - without any error, but after the next refresh the file is shown again.
However we have also not found any way to reproduce it.

Bye, Peer