Owncloud 9 blank screen

Hello everyone! I have problem with old owncloud 9.0.11. We had physical server, but datastore has failed, but before we copied all information from datastore.
We tried virtualize physical server. After that we mounted a new disk to /mnt/datastore (link the same)
I modified configuration of Mysql to standard path and imported sql dump (imported dump, because DB was on datastore)
Then on the web page I got error about data. It is correct, because data haven’t copied yet. After using rsync I copied data to /mnt/datastore on my server, change owner to apache:apache and got blank screen.
Could someonw help me please?

OS Centos 7
OC version 9.0.11


Disabling symbolic-links is recommended to prevent assorted security risks


Settings user and group are ignored when systemd is used.

If you need to run mysqld under a different user or group,

customize your systemd unit file for mariadb according to the

instructions in http://fedoraproject.org/wiki/Systemd


innodb_file_per_table = 1

include all files from the config directory

!includedir /etc/my.cnf.d


<?php $CONFIG = array ( 'updatechecker' => false, 'instanceid' => 'ocrrxt8trvz3', 'passwordsalt' => 'ifo6cIadC6DFJ99SvhRDegswmXGkxR', 'secret' => 'GcRM18+VwWeGOpwL4pQ2uFZcpWrhKe90SPqZPPuJUHqHFfSU', 'trusted_domains' => array ( 0 => 's3-owncloud', 1 => '192.168.0.xx', ), 'datadirectory' => '/mnt/storage/owncloud/data/', 'overwrite.cli.url' => 'https://s3-owncloud', 'dbtype' => 'mysql', 'version' => '', 'dbname' => 'owncloud', 'dbhost' => 'localhost', 'dbtableprefix' => 'oc_', 'dbuser' => 'root', 'dbpassword' => 'Maria_123', 'logtimezone' => 'UTC', 'installed' => true, 'loglevel' => 3, 'log_rotate_size' => 524288000, 'trashbin_retention_obligation' => 'auto, 14', );

Did you consider switching to ownCloud 10? Your data move might be a good opportunity, might by worth it. Nowadays almost nobody remembers oc9 and/or wants to support such requests.

Regarding your issue: Have a look at your owncloud.log

BTW, always remove sensitive information from config and log snippets in your posts.

1 Like

We are planning to switch to OC 10, after virtualizing OC 9. We tried update to Centos 8 w PHP 7, but we got problem with web freezing.
At the moment in owncloud.log I see that
{“reqId”:“YLSleT@xN9iKc9J5XdTYdgAAAAA”,“remoteAddr”:“”,“app”:“PHP”,“message”:“Can’t use method return value in write context at /var/www/html/owncloud/apps/onlyoffice/appinfo/application.php#66”,“level”:3,“time”:"202$

After opening web and pressing F12 I get HTTP 500 error and 404

Disable the onlyoffice app for the time being, and double-check the php version you’re using is supported by the OC version.

1 Like

how could I disable it without web?

You can disable it directly in the db.


That’s a hack, and as such, it should be used as a last resort. Command line is the way to go if web UI isn’t available (occ app:disable <appid>)


As long as you have shell access, of course. But I wouldn’t call it a hack, because the shell command does the same under the hood.

1 Like

Guys, thank you all! Web is working. I swtiched off onlyoffice and user_ldap. But now, I need to enable ldap, users need to download their files. After enabling I get error.

In my opinion, it is the result of previous ldap user.

We’ll likely need logs to know what’s happening.
In addition, note that I don’t think there are people knowing russian (?) that could help, so people would appreciate a quick translation to English from non-English text.


Sorry, it was my mistake.
I’ve found in logs, after enabling ldap, error
{“reqId”:“YLd7pZE2-e@rjEVmuH-4kwAAAAE”,“remoteAddr”:“”,“app”:“index”,“message”:“Exception: {“Exception”:“OC\\ServerNotAvailableException”,“Message”:“Lost connection to LDAP server.”,“Code”:0,“Trace”:”#0 \/var\/www\/html\/owncloud\/apps\/user_ldap\/lib\/ldap.php(256): OCA\\user_ldap\\lib\\LDAP->postFunctionCall()\n#1 \/var\/www\/html\/owncloud\/apps\/user_ldap\/lib\/ldap.php(42): OCA\\user_ldap\\lib\\LDAP->invokeLDAPMethod(‘bind’, Resource id #374, ‘CN=owncloud,CN=…’, ‘there_was_pass’)\n#2 \/var\/www\/html\/owncloud\/apps\/user_ldap\/lib\/connection.php(596): OCA\\user_ldap\\lib\\LDAP->bind(Resource id #374, ‘CN=owncloud,CN=…’, ‘there_was_pass’)\n#3 \/var\/www\/html\/owncloud\/apps\/user_ldap\/lib\/connection.php(543): OCA\\user_ldap\\lib\\Connection->bind()\n#4 \/var\/www\/html\/owncloud\/apps\/user_ldap\/lib\/connection.php(154): OCA\\user_ldap\\lib\\Connection->establishConnection()\n#5 \/var\/www\/html\/owncloud\/apps\/user_ldap\/lib\/connection.php(162): OCA\\user_ldap\\lib\\Connection->init()\n#6 \/var\/www\/html\/owncloud\/apps\/user_ldap\/lib\/access.php(156): OCA\\user_ldap\\lib\\Connection->getConnectionResource()\n#7 \/var\/www\/html\/owncloud\/apps\/user_ldap\/user_ldap.php(219): OCA\\user_ldap\\lib\\Access->readAttribute(‘cn=???..’, ‘’, ‘(&(|(objectclas…’)\n#8 \/var\/www\/html\/owncloud\/apps\/user_ldap\/user_ldap.php(275): OCA\\user_ldap\\USER_LDAP->userExistsOnLDAP(Object(OCA\\user_ldap\\lib\\user\\User))\n#9 \/var\/www\/html\/owncloud\/lib\/private\/user\/manager.php(138): OCA\\user_ldap\\USER_LDAP->userExists(‘9AFA180A-E7EE-4…’)\n#10 \/var\/www\/html\/owncloud\/lib\/private\/user.php(392): OC\\User\\Manager->get(‘9AFA180A-E7EE-4…’)\n#11 \/var\/www\/html\/owncloud\/lib\/public\/user.php(79): OC_User::getDisplayName(‘9AFA180A-E7EE-4…’)\n#12 \/var\/www\/html\/owncloud\/lib\/private\/share\/share.php(1926): OCP\\User::getDisplayName(‘9AFA180A-E7EE-4…’)\n#13 \/var\/www\/html\/owncloud\/lib\/private\/share\/share.php(337): OC\\Share\\Share::getItems(‘file’, NULL, -1, ‘there_was_user’, NULL, -1, NULL, -1, false, false, true, true)\n#14 \/var\/www\/html\/owncloud\/lib\/public\/share.php(124): OC\\Share\\Share::getItemsSharedWithUser(‘file’, ‘there_was_user’, -1, NULL, -1, false, true)\n#15 \/var\/www\/html\/owncloud\/apps\/files_sharing\/lib\/mountprovider.php(60): OCP\\Share::getItemsSharedWithUser(‘file’, ‘there_was_user’, -1, NULL, -1, false, true)\n#16 \/var\/www\/html\/owncloud\/apps\/files_sharing\/lib\/mountprovider.php(71): OCA\\Files_Sharing\\MountProvider->getItemsSharedWithUser(‘there_was_user’)\n#17 \/var\/www\/html\/owncloud\/lib\/private\/files\/config\/mountprovidercollection.php(70): OCA\\Files_Sharing\\MountProvider->getMountsForUser(Object(OC\\User\\User), Object(OC\\Files\\Storage\\StorageFactory))\n#18 [internal function]: OC\\Files\\Config\\MountProviderCollection->OC\\Files\\Config\\{closure}(Object(OCA\\Files_Sharing\\MountProvider))\n#19 \/var\/www\/html\/owncloud\/lib\/private\/files\/config\/mountprovidercollection.php(71): array_map(Object(Closure), Array)\n#20 \/var\/www\/html\/owncloud\/lib\/private\/files\/filesystem.php(432): OC\\Files\\Config\\MountProviderCollection->getMountsForUser(Object(OC\\User\\User))\n#21 \/var\/www\/html\/owncloud\/lib\/private\/files\/filesystem.php(353): OC\\Files\\Filesystem::initMountPoints(‘there_was_user’)\n#22 \/var\/www\/html\/owncloud\/lib\/private\/util.php(223): OC\\Files\\Filesystem::init(‘there_was_user’, ‘\/there_was_user\/file…’)\n#23 \/var\/www\/html\/owncloud\/lib\/base.php(906): OC_Util::setupFS()\n#24 \/var\/www\/html\/owncloud\/index.php(47): OC::handleRequest()\n#25 {main}",“File”:"\/var\/www\/html\/owncloud\/apps\/user_ldap\/lib\/ldap.php",“Line”:283}",“level”:3,“time”:“2021-06-02T12:37:57+00:00”,“method”:“GET”,“url”:"/index.php/core/js/oc.js?v=979488f5baa8b940a784efebde009ca7",“user”:“there_was_user”}
Does it mean, that server just cannot connect to ldap server? Or password is incorrect?
And one more question, how could I change the ip, user and password?

Either you cannot access to the LDAP server, or there is a timeout. That’s something you have to investigate. You can use other tools to ensure the connection is ok.

I’m not sure what you mean. Most of the information about the user is taken from the LDAP server, except of some things that can’t be mapped easily.


i will repeat, I’m going to upgrade to OC 10, but after repairing this

I mean, change it in DB. because ip 0.14 it is mail server, not a DC. Change user and password for using LDAP

Check in the ownCloud’s settings page with the admin user. There is a section to configure the ownCloud’s user_ldap app (assuming it’s enabled).

I think you can also configure it through command line, although it’s more difficult.


Sorry, but after disabling user_ldap app in DB, I don’t have this section in web. So I need to configure it from CLI. Could you, please, tell me how can I change config?

You can enable the app again from the web UI. Settings > apps > disabled apps. You’ll find the ldap app there. Once enabled, just reload the page and the user authentication section will appear.

1 Like

It doesn’t work. When I’m trying enable from web, I get error “This app affect to web perfomance”

Check that the version of the app is compatible with the version of ownCloud.
Need logs to know what’s going on.


@jvillafanez Ok, I’m close to solving the problem. I’ve downloaded user_ldap 0.9.1 and cipoied to /apps/ folder. But now I get error, that this version works only on OC 10 and higher. MB someone can give me his user_ldap folder for OC 9?