Owncloud 9 - MariaDB “READ COMMITED” transaction isolation level


#1

Bonjour,

si je suis la doc "https://doc.owncloud.org/server/9.1/admin_manual/configuration_database/linux_database_configuration.html", il faudrait configurer transaction-isolation = read committed

Sauf qu'avec cette ligne mon serveur mariadb ne démarre plus (inséré dans le fichier /etc/mysql/conf.d/mariadb.cnf,.
Le truc, c'est que jusqu'à hier pas de soucis. J'avoue ne pas comprendre...

Ma question est donc de savoir si cela est vraiment nécessaire.

Si vous aviez une idée?

Merci de votre aide,

D


#2

Je n'ai pas vu cette option dans le document. Il y a:
BINLOG_FORMAT = MIXED

Je pense dans la plupart des configurations ca fonctionne. Sinon tu auras les messages indiqués dans le document.


#3

si si je confirme:

https://doc.owncloud.org/server/9.1/admin_manual/configuration_database/linux_database_configuration.html#db-transaction-label

en plus du "binlog_format"

j'ai trouvé mon erreur.

j'avais mis la ligne en minuscule. Et ça, ça lui plait pas!!!!

Grrrr

par contre j'ai désactivé binlog_format....Apparemment on peut soit le configurer soit le désactiver...

Merci en tout cas