Owncloud access from WAN

Owncloud X V10.0.10
Running on QNAP TS873A V5.0.1.2145

The problem I am experiencing is that I am unable to access my Owncloud via the WAN

In essence the message says that I need to add my Trusted Domain details.

This is where I am struggling.

I can access my QNAP from the WAN using the following

https://mydomainname.myowncloud.com:4431
(Missing out the port number takes me to my router???)

What I have done in the past is simply tag “owncloud”, onto the URL and it worked, albeit on a much old QNAP device!

https://mydomainname.myowncloud.com:4431/owncloud

When I attempt the above now, I receive an error message which states “Page not found”.

My next approach was to try the following URL

I access owncloud on my LAN using the following: -

QNAPipaddress:4490

This works OK

What does not work is: -

http://mydomainname.myqnapcloud.com:4490

This takes me to the landing page for Owncloud with the message suggesting that I need to modify my Trusted Domains in config/config.php

I am lost at this point. I can SSH from my Mac Terminal session onto the QNAP device, but don’t really know what to do next. I would really appreciate it if somebody could outline the commands to allow me to add my domain name to the said config file. I have spent hours on Google but most of the posts and written in such a way that the reader, i.e. me, has some prior knowledge, I have not!

Thanks in anticipation

You have to edit the file config/config.php.
There is an array that contains trusted domains, you have to add your external/WAN domain there. Example:

'trusted_domains' => 
  array (
    0 => 'internal-domain',
    1 => 'external domain',
  ),

Give it a try.

I really appreciate your prompt reply. I have enough knowledge on how to SSH from my Mac Terminal program to the QNAP device, but that’s as far as I can get. I fully appreciate what you suggesting I try. Allthough I have a list of commands I am unable to navigate to the appropriate folder to edit said config.php file. Is there a crash course available???

Kind regards

Sorry to be a nuisance. After much head scratching I was able to find the config.php file, I made a copy of it before editing the original. Unfortunately after editing the array as suggested owncloud stopped working all together. I put the original config.php file back and am still experiencing problems. When I try to access owncloud by any method, I get the following: -
Warning : fopen(/var/www/html/config/config.php): failed to open stream: Permission denied in /var/www/html/lib/private/Config.php on line 251

Warning : flock() expects parameter 1 to be resource, boolean given in /var/www/html/lib/private/Config.php on line 261

Fatal error : Uncaught Error: Call to a member function getLogger() on null in /var/www/html/index.php:72 Stack trace: #0 {main} thrown in /var/www/html/index.php on line 72

It’s a very big ask, but have you any ideas what these error messages mean? I am contemplating-loading owncloud and starting again. Do think this is the way forward please?

Again, I can’t tank-you enough for you help so far, I have a bit of a steep learning curve when using SSH but have enjoyed the experience.

Kind regards

Well, I assume your editing of file config.php changed its permission. This file must be fully accessible by the web server.
But I have no clue about QNAP, how to change file ownership there. I think you’d better place a question in a QNAP forum.

BTW, ownCloud docs has own section for QNAP, maybe this can help as well.