ownCloud and FTP

help

#1

hi to all
I've a debian 7 server, with proftpd
users are system users, proftpd doesn't use mysql or other authentication system
users' folders are in /var/ftp: /var/ftp/user1, /var/ftp/users2 and so on
I've installed ownCloud with "user pam auth" app, that works only with about 10 users, others can't login
Furthermore, after they have logged in, how I can give access to their ftp folder? I've tried with a symbolic link, but user can't see it.
thanks


#2

Try to use the external storage app:

https://doc.owncloud.org/server/9.1/admin_manual/configuration_files/external_storage_configuration_gui.html

with the:

https://doc.owncloud.org/server/9.1/admin_manual/configuration_files/external_storage/ftp.html

mount option where you can include external FTPs within ownCloud.


#3

thanks
tried, but it doesn't work, probably because my server use ftpes
in any case, in the configuration I've to specify username and password of a single user, in my case every user has his own credential


#4

The external storage app is also supporting FTPs. Each user can also use the FTP with his own credentials, not one single credential.


#5

I think do you mean that I can allow users to add an external storage, but it's not easy for them, they are not expert. and however it doesn't work, there is some problem with ftp server, my log tells me that "chdir("/"): Access denied"
thanks again

EDIT: after upgrading ownCloud now I can specify "session credential" in ftp configuration, very useful. but chdir error remains.

EDIT2: I tried with another user, no error but I can't see anything, the folder seems empty


#6

update: I can connect ftp, but I can't see the content
if I create files or folders from onwCloud, I see them
if there are files or folders created from FTP, I can't
permissions are the same


#7

See:

https://doc.owncloud.org/server/9.1/admin_manual/configuration_files/external_storage_configuration_gui.html#detecting-files-added-to-external-storages

if externally added files won't be detected by ownCloud. If permissions are correct ownCloud will detect those files.


#8

understood thanks
but I use session credential, so I've this error:

"Error while scanning, storage not available (No session credentials saved)"

EDIT: I've tried to create a symbolic link and run a manual scanning with --path, but nothing happens / nothing changes


#9

You cannot scan/detect changed files on external storage mounts when you select the Log-in credentials, save in session authentication mechanism. However, there is a workaround, and that is to use Ajax cron mode. See Password-based Mechanisms for more information.

from the link above... However "Ajax cron" needs users actively browsing the webgui so it is running and able to do the scanning jobs.


#10

sorry but I can't
I don't understand how to configure ajax cron, where I have to add my code?
I've tried "sudo -u www-data php occ background:ajax" but this only changes the default cron system
after that, my ftp folder inside ownlcoud is disappeared, I tried to delete and recreate external storage but now it doesn't work any more


#11

The problem is when you have configured a cronjob it will automatically switch back to cron the next time the cronjob runs. However it is strange that it works with Ajax and not cron.

Perhaps a good candidate for a bug report on github. Which version are you using? Did you try the recent updates (9.0.5 or 9.1.1)?


#12

I don't know how to configure ajax cron, with "normal" cron I launch, from console, "crontab -e" and then edit it
but with ajax cron? where I put my code?

I'm running 8.2.7 under Debian 7
there is no automatic update, I shoud do it manually


#13

Please read:

https://doc.owncloud.org/server/9.1/admin_manual/configuration_server/background_jobs_configuration.html

The "Ajax" background mode is triggered when users actively browsing your webpage.


#14

sorry but I still dont' understand, maybe my english is not good enough
ok with ajax method, I have setup it, but WHERE / HOW I specify WHAT cron have to do? where I put my code "sudo -u www-data php occ files:scan --username" ?
the guide explain what cron is and how it works, and how to launch cron.php, but where I specify what to do? I've to edit cron.php and add code there?


#15

Hi,

  1. you CAN'T USE files:scan at all when having the "Log-in credentials, save in session authentication" mechanism configured
  2. You NEED to set the background job to "Ajax"
  3. You DON'T NEED ANY modification to the source code of ownCloud
  4. You NEED users browsing your webpage when having "Ajax" configured so that external added files are detected