ownCloud Appliance doesn't work


#1

Steps to reproduce

  1. Download OVA file
  2. Start VM

Expected behaviour

I expect to log in and configure the appliance: IP address, hostname, etc.....

Actual behaviour

Shortly after boot a dialog box appears the the following:
"
An error occurred.
Internal server message: Could not connect to the module process.
Server error message:
Connection to the module process failed.
OK
"
If I click OK, then the wheel spins forever....

Server configuration

Operating system:
Fedora with VirtualBox-5.1-5.1.30_118389
ownCloud appliance version: 10.0.3

Where did you install ownCloud from:
From the ownCloud download page.

The appliance never fully starts up. I thought the appliance was pre-configured to just "work" ?

Any ideas welcome.


#2

Worked for me several days ago. Try redownloading the OVA again and avoid changing the imported configuration (just in case). In addition, make sure SELinux isn't causing any problem.


#3

Thanks for the info. Actually, I didn't change the VM configuration. It seems that it never really booted up; it got past GRUB and that was it. I didn't have time to go "under the covers", as I figured it should have worked. Perhaps there's some issue with compatibility with my version of VirtualBox...
Another thought is that it was trying to access the network, and got hung up somehow. I built it in a DMZ and there's no DHCP server. I've noticed that most appliances assume there's DHCP available, and get upset when there's no network. Why to appliance developers leave the network setup until the very end when it's often the most important stage?
I've since found the Turnkey Linux VM of ownCloud here: https://www.turnkeylinux.org/owncloud
It works perfect and is half the size.


#4

You are correct to assume the appliance needs a DHCP Server.

Just out of curiosity - have you just downloaded the appliance and tried to start it or did you have a look at the documentation?


#5

Thanks for your reply.
I did indeed read the documentation: https://owncloud.org/wp-content/uploads/2017/12/ownCloud_User_Guide_Appliance_ENG.pdf
However it all assumes that boot-up has completed. The appliance documentation discusses configuring the hostname, networking,etc and then the application, and setting passwords, etc. But if the appliance never completes the boot process, then documentation is not of much use. The documentation does not mention any specific minimum version requirements for VirtualBox, or the fact that it needs a DHCP server on the network. Will the lack of a DHCP server prevent it from booting and getting to the setup stage?


#6

You are correct. It's not in the documentation and not on the website.

Now if you go to the owncloud.com site it states that you need Internet access and a DHCP server:

also the real documentation is here

https://doc.owncloud.com/server/10.0/admin_manual/appliance/

What you have linked is a white paper, like a condensed quick start document.


#7

Thanks for the update.
"Not in the documentation and not on the website" - will this be corrected ?
The document I obtained is on the same page where I downloaded the appliance - why would I have thought to look elsewhere ? Further, with a document title "Setting up your ownCloud. Step-by-Step to our ownCloud instance." why would I doubt what it was going to tell me, and look elsewhere?
The link you provided indicates that "Internet access and a DHCP server is required to use the appliance", not to install it. Even then, perhaps someone might want to use it internally on their network - they wouldn't need Internet access to use it...or would they ?
What you have indicated as the "real" documentation is not much more than the document I was reading - at least as far as installation is concerned. In terms of installation, they are 99% the same.
The procedure in the "real" documentation (as well as the PDF) for obtaining the appliance is wrong. I could simply download it from "https://owncloud.org/download/" without sending an email to anyone. Let me guess; that was not the "real" place to the obtain the appliance ? The problem is that there is ownCloud.com and ownCloud.org, and the .org document is the same as the .com info, but the .org document doesn't match the fact I could download the appliance without sending an email.
For the benefit of other readers, you gave me the wrong site for the latest "real" documentation. It should be: https://doc.owncloud.com/server/latest/admin_manual/appliance/
...noting that it's for the appliance from owncloud.com.
As mentioned, (for me) the appliance doesn't boot far enough to even begin the setup procedure, so all the documentation is of no use anyway. None of the guides give any troubleshooting information.
I can only assume that the appliance works, so perhaps I'm doing something wrong.
My questions still remain open:
1. Will the lack of a DHCP server prevent it from booting and getting to the setup stage?
2. Is a specific minimum version of VirtualBox required ?


#8

Can you sum up your question?

This sounds to me like you are looking for a mistake, instead of thinking. Also the volume of your text indicates to me that you are upset. Try to calm down and collect your thoughts.

Is the Documentation for the Appliance perfect? - No
Are we trying to improve it? - Yes
Is simply complaining about it gonna help - Probably not


#9

Hello,

Was this ever resolved? I have the same issue, download the OVA, import appliance in virtual box (which has other linux versions running fine on it) gets part way through booting first time and fails / hangs in the same way as above.

As also mentioned above, I have read the documentation on the download page as suggested, which advises how to download virtual box and import the appliance accepting defaults. The documentation then jumps to the appliance having booted and how to configure it, it does not seen to deal with issues during boot.

Thanks for your help
Andrew


#10

Does your system have internet access and a dhcp server?
The appliance needs those 2 things.


#11

Thank you for getting back to me.

I am no expert, so forgive me. Yes, the computer and other virtual machines have access to the internet, and I presume they have acces to a DHCP as ifconfig lists IPv4 and IPv6 addresses (on the other virtual machines).

In case it helps, I am running windows 10 with VirtualBox and two other ubuntu instilations working quite happily.

Andrew

Edit... The physical computer's network and internet settings auto configure, in windows, from the modem router's DHCP


#12

Okay, what mode is your virtual machine with the appliance set to?

Soon a new Appliance will be released, I hope it will fix this bugs.

Although I am not quite sure what the cause of errors is. I am setting in the appliance onna weekly basis and everything is good.

Have you tried to enter the VM in the VM screen?
Have you got the email with the license?


#13

Hello, I was not asked for an email address for a licence, but my appliance does not boot far enough for me to enter one.

I do not know what mode virtual box is in. How do i check that? what mode should it be in?

Thank you
Andrew


#14

Despite having tried it several times in a row on more than one occasion, and having re downloaded it again, still with no luck, it seems to have taken to working on the second attempt each and every reboot of the physical computer, and then working fine regardless of how many times you shut the appliance down. Once you reboot it it fails as above first time and works after that. I have changed nothing, so do not know what has caused this change.I have as such been able to go through the set up.


#15

You select your virtual machine in the virtual box UI.

Then you either click on the gear button or right click on it and go to settings.

There you have the network settings.

Your VM should be in bridged mode, there you see your interface. Make sure the interface is working and connected to the internet.

It would be helpful if you would write down all the steps you are making and where the error occurs?

If your error is - you reboot the VM and the loading screen get stuck - this is a known issue. As far as I know it's only a cosmetic issue, since you can access the VM via SSH or just hitting enter in the VM.