Owncloud client asks for authorization my every account every time I change the network or suspend computer

Expected behaviour

After each account in desktop application has been authorized it should be kept until uninstalled or moved to another device.

Actual behaviour

After changing the network computer is connected to or suspending computer for longer time application requires to authorize randomly all or most of accounts again opening browser with login window in tab for each desktop client account.

Steps to reproduce

  1. Install owncloud client latest version on latest one Mac OS X
  2. add few accounts to owncloud client
  3. enable TOTP and OAuth addons on server
  4. authorize each account on server to get connected

Server configuration

Operating system:
Centos 7 latest
Web server:
Apache 2.4 latest for Centos distro
Database:
mysql Ver 15.1 Distrib 5.5.68-MariaDB
PHP version:
7.3.29
ownCloud version:
10.7.0.4
Storage backend (external storage):
none

Client configuration

Client version:
2.8.2
Operating system:
MacOSX BigSur 11.4
OS language:
English
Qt version used by client package (Linux only, see also Settings dialog):

Client package (From ownCloud or distro) (Linux only):

Installation path of client:
default

Logs

Please use Gist (https://gist.github.com/) or a similar code paster for longer
logs.

Template for output < 10 lines

  1. Client logfile: Output of owncloud --logwindow or owncloud --logfile log.txt
    (On Windows using cmd.exe, you might need to first cd into the ownCloud directory)
    (See also http://doc.owncloud.org/desktop/2.2/troubleshooting.html#client-logfile )

  2. Web server error log:

  3. Server logfile: ownCloud log (data/owncloud.log):

please check again with the 2.9.0-RC1:
mac | download.owncloud.com

1 Like

Hi @michaelstingl,
I just installed suggested verion and will let you know how it works.
Thanks anyway!

H @michaelstingl!
Unfortunately mac’s desktop client still asks for password but less frequently than before.
Is ther anything more I can do about it? We have several mac users and all strongly complains about it including myself.

Hello again!
Any other suggestions to solve this issue?
I’ve installed latest stable release and problem still occurs - is there anything I can do about it?
Thanks!