Owncloud-client linux mint 18.3 64 bit libowncloudsync0 (= 2.4.0-8911)


#1

Expected behaviour

Tell us what should happen

Actual behaviour

De volgende pakketten hebben niet-voldane vereisten:
owncloud-client : Vereisten: libowncloudsync0 (= 2.4.0-8911) but it wont be installed
Vereisten: ocqt562+240-libqt5core5a but it wont be installed
Vereisten: ocqt562+240-libqt5dbus5 but it wont be installed
Vereisten: ocqt562+240-libqt5gui5 but it wont be installed
Vereisten: ocqt562+240-libqt5keychain1 but it wont be installed
Vereisten: ocqt562+240-libqt5network5 but it wont be installed
Vereisten: ocqt562+240-libqt5webkit5 but it wont be installed
Vereisten: ocqt562+240-libqt5widgets5 but it wont be installed
Vereisten: ocqt562+240-libqt5xml5 but it wont be installed
Vereisten: owncloud-client-l10n but it wont be installed
Vereisten: ocqt562+240-libqt5sql5-sqlite but it wont be installed

Server configuration

Operating system: Centos

Web server:
CentOS 7.4.1708
Database:

PHP version:
7.1
ownCloud version:
10.0.6
Storage backend (external storage):

Client configuration

Client version:
2.4
Operating system:
linux mint 18.3
OS language:
NL
Qt version used by client package (Linux only, see also Settings dialog):

Client package (From ownCloud or distro) (Linux only):

Installation path of client:


#2

Hi,

could you specify your question?


#3

If i want to install the downloaded owncloud-client desktop in linux mint i got the error

error: dependence is not fulfillable libowncloudsync0 (=2.4.0-8911)

When i install owncloud-client with the command apt-get install owncloud-client and i start the application and fill in the site username and password i got

Error downloading https://sitename/remote.php/webdav/ - server replied:forbidden (unsupported client version)

I hope you know what to do?

greetings justin


#4

Do you download the current version of the client?


#5

I tried owncloud-client_2.4.0-8911_amd64.deb

then i got the error error: dependence is not fulfillable libowncloudsync0 (=2.4.0-8911)

greetings


#6

I've the same issue - still no solutions for that?


#7

How did you install the owncloud client?


#8

Tried it with these package sources: https://software.opensuse.org/download/package?project=isv:ownCloud:desktop&package=owncloud-client

I'm using Linux Mint 18.1 Cinnamon 64bit.


#9

Did you use the Ubuntu repository?


#10

Yes. I've always used it. But since updating our server to 10.0.6 it was requiring the newest version, which I can't install.

This errors I've received by installing with apt:

sudo apt-get install owncloud-client
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 owncloud-client : Depends: libowncloudsync0 (= 2.4.0-8911) but 2.1.1+dfsg-1ubuntu1.1 is to be installed
                   Depends: ocqt562+240-libqt5core5a but it is not going to be installed
                   Depends: ocqt562+240-libqt5dbus5 but it is not going to be installed
                   Depends: ocqt562+240-libqt5gui5 but it is not going to be installed
                   Depends: ocqt562+240-libqt5keychain1 but it is not going to be installed
                   Depends: ocqt562+240-libqt5network5 but it is not going to be installed
                   Depends: ocqt562+240-libqt5webkit5 but it is not going to be installed
                   Depends: ocqt562+240-libqt5widgets5 but it is not going to be installed
                   Depends: ocqt562+240-libqt5xml5 but it is not going to be installed
                   Depends: ocqt562+240-libqt5sql5-sqlite but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

#11

You are trying to install 2 different versions.
Does this command work for you?
sudo apt-get install --only-upgrade owncloud-client


#12

Unfortunately I've already uninstalled the previous version 2.1.1.


#13

This line is saying other things...


#14

So, I was able to fix that problem by installing some of the missed packages by hand.
Thanks for your help!


#15

@tdeuling Would you mind sharing the solution you used to fix this issue? Thank you!