Owncloud connection problems

I’ve been using owncloud for apparently a year-and-a-half now (that’s the uptime on the small server that hosts it). It’s been working just fine. And then in the last couple of weeks, somehow it suddenly stopped working.

The Linux desktop app says; no connection to owncloud at

When I point a browser at that URL, I get a login screen and I can look at my files. Seems to work. But the app is not working. Where do I look to find out what’s going wrong?

Logfiles?

Without filling up the requested template, at least with the most relevant parts, its nearly impossible to help.

Yeah. I checked the “owncloud logfile”.

{"reqId":"zSKkiDaTrtetByhaVYXp","level":4,"time":"2021-12-22T23:36:19+00:00","remoteAddr":"192.168.235.32","user":"wolff","app":"webdav","method":"PUT","url":"\/owncloud\/remote.php\/webdav\/CameraUpload\/IMG_20211222_221410.jpg-chunking-4725-4-0","message":"Exception: HTTP\/1.1 400 expected filesize 1024000 got 447432: {\"Exception\":\"Sabre\\\\DAV\\\\Exception\\\\BadRequest\",\"Message\":\"expected filesize 1024000 got 447432\",\"Code\":0,\"Trace\":\"#0 \\\/var\\\/www\\\/owncloud\\\/apps\\\/dav\\\/lib\\\/Connector\\\/Sabre\\\/File.php(152): OCA\\\\DAV\\\\Connector\\\\Sabre\\\\File->createFileChunked(Resource id #30)\\n#1 \\\/var\\\/www\\\/owncloud\\\/apps\\\/dav\\\/lib\\\/Connector\\\/Sabre\\\/Directory.php(172): OCA\\\\DAV\\\\Connector\\\\Sabre\\\\File->put(Resource id #30)\\n#2 \\\/var\\\/www\\\/owncloud\\\/lib\\\/composer\\\/sabre\\\/dav\\\/lib\\\/DAV\\\/Server.php(1091): OCA\\\\DAV\\\\Connector\\\\Sabre\\\\Directory->createFile('IMG_20211222_22...', Resource id #30)\\n#3 \\\/var\\\/www\\\/owncloud\\\/lib\\\/composer\\\/sabre\\\/dav\\\/lib\\\/DAV\\\/CorePlugin.php(504): Sabre\\\\DAV\\\\Server->createFile('CameraUpload\\\/IM...', Resource id #30, NULL)\\n#4 \\\/var\\\/www\\\/owncloud\\\/lib\\\/composer\\\/sabre\\\/event\\\/lib\\\/WildcardEmitterTrait.php(89): Sabre\\\\DAV\\\\CorePlugin->httpPut(Object(Sabre\\\\HTTP\\\\Request), Object(Sabre\\\\HTTP\\\\Response))\\n#5 \\\/var\\\/www\\\/owncloud\\\/lib\\\/composer\\\/sabre\\\/dav\\\/lib\\\/DAV\\\/Server.php(470): Sabre\\\\DAV\\\\Server->emit('method:PUT', Array)\\n#6 \\\/var\\\/www\\\/owncloud\\\/lib\\\/composer\\\/sabre\\\/dav\\\/lib\\\/DAV\\\/Server.php(251): Sabre\\\\DAV\\\\Server->invokeMethod(Object(Sabre\\\\HTTP\\\\Request), Object(Sabre\\\\HTTP\\\\Response))\\n#7 \\\/var\\\/www\\\/owncloud\\\/lib\\\/composer\\\/sabre\\\/dav\\\/lib\\\/DAV\\\/Server.php(319): Sabre\\\\DAV\\\\Server->start()\\n#8 \\\/var\\\/www\\\/owncloud\\\/apps\\\/dav\\\/appinfo\\\/v1\\\/webdav.php(65): Sabre\\\\DAV\\\\Server->exec()\\n#9 \\\/var\\\/www\\\/owncloud\\\/remote.php(165): require_once('\\\/var\\\/www\\\/ownclo...')\\n#10 {main}\",\"File\":\"\\\/var\\\/www\\\/owncloud\\\/apps\\\/dav\\\/lib\\\/Connector\\\/Sabre\\\/File.php\",\"Line\":495}"}
Doesn’t tell me anything.

I tried the apache log file and, it looks as if there is NO contact at all with the server.

So I’m guessing I want to look at the client logfile. But without a connection, I can’t find any!
I can click “activity” and then server activity is empty, sync protocol is empty, not synced is empty. Under “general” I can configure some stuff, but it doesn’t look like there is a log there. Network: Again some settings but no log.

So… which logfile are you suggesting I take a look at?

I just recognized that the problem relates to an app only.

Which one? Desktop, Android, iOS? You really should deliver such info unasked. Anyway, I cannot give further help at this point, as I don’t use any of these client apps.

I didn’t mention that I run Linux on my desktop. Sorry, that seems obvious to me.

The fact that it was the desktop app that said it could not connect is in the opening post. Check your glasses. The fact that the server seems to be working ok is mentioned in the opening post. You can conclude that I verified connectivity between client and server that way.

I’ve done some more digging. The Linux desktop app connects to 78.47.204.111 (https) which reverse maps to sunny.owncloud.systems. It does NOT attempt to connect to 192.168.x.y = my server.

Sorry for disturbing you. Good luck.

I see that you have a basic auth in front of your ownCloud instance on the domain you posted here (perhaps remove it now again?). This is not supported as ownCloud uses basic auth internally.

So I guess basic auth was just recently introduced?

I know “basic auth” as what happens when I put stuff in .htaccess and .htpasswd . Is that what you mean?

I do not have .htaccess configured in the owncloud directory.

When I go to http://[name-of-my-server-machine]/ I get the ubuntu default apache2 page. when I attach /owncloud, I get the owncloud login, no “basic auth” requests. (“Please enter your username and password”).

EDIT: Why must the forum ignore part of the stuff I type???

Where did you download the desktop client from?
I haven’t seen any reference to that address in the code in github, and as far as I know, the official client lets you to connect to any server you want, so unless you’re telling the client to connect to that address, it shouldn’t connect there at all.

There could be customized desktop clients with harcoded addresses, but normally they don’t let you change it. It’s pretty weird that it breaks without touching.
Maybe it’s a dns problem? maybe you expect the “my.server” address resolves to your server in 192.168.x.y but it’s resolving to a different ip address?