Owncloud creates zip file that cannot be opened by file-roller

9.0.x
help

#1

Steps to reproduce
1. Upload a few files (or optionally a folder containing files)
2. Download multiple files at once by selecting them (or by downloading a folder) on the website
3. Try to open the zip file with gnome file roller

Expected behaviour
The zip file should open fine

Actual behaviour
file-roller prompts: "An error ocurred while loading the archive"
The archive is not corrupted and I can open it with other tools such as unzip. This is probably a problem with file-roller not supporting that type of zip. But as file-roller is quite popular I'd like my owncloud to produce zip files that can be opened with file-roller. Is there any workaround?

Server configuration
Operating system: Debian Wheezy
Web server: Apache2
Database: MySQL
PHP version: 5.6
ownCloud version (see ownCloud admin page): 9.0.4
Updated from an older ownCloud or fresh install: updated (initially started from 8.0.x)
ownCloud log (data/owncloud.log, see https://central.owncloud.org/t/how-to-find-webserver-or-oc-logfile-enable-php-logfile/808): No errors ocurred

Special configuration (external storage, external authentication, reverse proxy, server-side-encryption): server-side-encryption

Integrity status for oC9+
There seems to be an issue with the certificate of the tasks app that I couldn't fix yet. But this is unrelated to this issue.

Technical information
=====================
The following list covers which files have failed the integrity check. Please read
the previous linked documentation to learn more about the errors and how to fix
them.
Results
=======
- tasks
	- EXCEPTION
		- OC\IntegrityCheck\Exceptions\InvalidSignatureException
		- Certificate has been revoked.
Raw output
==========
Array
(
    [tasks] => Array
        (
            [EXCEPTION] => Array
                (
                    [class] => OC\IntegrityCheck\Exceptions\InvalidSignatureException
                    [message] => Certificate has been revoked.
                )
        )
)

#2

Please report this directly to the bugtracker:

https://github.com/owncloud/core/issues

Probably related to this issue with lacking zip64 support on Mac OS X which might be also missing in your file-roller version:


#3

I investigated this a bit further and it seems that it may not be a bug in file-roller but in owncloud after all. Although unzip can extract the archive a test of the file yields:

$ unzip -T download.zip
note:  didn't find end-of-central-dir signature at end of central dir.

This isn't related to the Mac OS X bug I think.
However because unzip is able to open the archive I filed a bug to gnome: https://bugzilla.gnome.org/show_bug.cgi?id=769083
Also I did what you suggested and filed a bug at github: https://github.com/owncloud/core/issues/25580


#4

Note that everything worked with oc 8.0.x
Is there a fast workaround I could do (independently from the bug reports)? I'd like to avoid trying a downgrade.


#5

Fast workaround is to not use file-roller but another tool like xarchiver or similar which might be able to handle the archive.


#6

That is not exactly what I meant. I wouldn't even mind using terminal commands. But there are many friends and colleagues accessing my server. They are using all sorts of operating systems and archive tools and have different levels of computer skills. I'm just fearing that I'm not the only one having this issue.
However I guess I have to be more patient. Thanks for your help anyway.


#7

Hi,

if it is that urgent and it worked with oC 8.0.x then your only possibility is probably to revert to your backup before the upgrade. Personally i don't think that its possible to provide a workaround that quick, especially as it is now weekend for most of the developers.


#8

The tasks app author had asked for his key to be revoked. We are currently issuing a new one and there will be an update available on the app store soon.


OC version info for apps