ownCloud Desktop with OpenID must sign in anew at every launch

We have ownCloud authenticating via OpenID and have found that the desktop apps must sign in fresh every time they’re launched. We have session idle and max set to 30 days, including for offline sessions. Active token lifespans are also 30 days. If the desktop app is running on a machine that goes to sleep, it runs for weeks without requiring a new login. If the machine is shut down or if ownCloud is quit, then we have to sign in again. Is there any way to have ownCloud desktop keep its tokens through shutdown so everything works at startup based on previous authentication?

Sure, this is the way it should work. Whenever the desktop sync client starts, it uses the persisted refresh_token to get a new access_token. Then the access_token is used in all requests.

You can check with any of the OIDC based demo instances:
Continuous Deployment | ownCloud

Right. We have our refresh token lifespan set to 30 days, so a fresh login shouldn’t be required to get an access token. That’s not happening with the desktop clients, though… they always require a fresh login anytime they’ve been shutdown completely.

The other issue is that when restarting the ownCloud desktop app doesn’t launch the browser for authentication. OwnCloud sits unable to connect until you go to settings for that account and click on the re-open browser button. Once you manually click that button, a browser opens and authentication goes through and ownCloud desktop is happy again.

Some people using the desktop app don’t notice it’s disconnected until they realize their files aren’t sync’ing and then don’t know how to remedy that.

Update: we’ve gotten the tokens working fine - no need to sign in anew. But, ownCloud desktop is still stuck not launching the browser for authentication. We have to manually go into ownCloud settings and click the “re-open browser” button every time ownCloud starts, otherwise it sits disconnected and doesn’t sync any files.