Hi,
i am running owncloud docker version (owncloud/server) and for customization and easy development i tried to run the docker with volumes and its generating errors.
This is the command i used to run docker of owncloud:
sudo docker run -v /home/dev/Desktop/cloud-docker:/var/www/owncloud -p 8080:8080 owncloud/server
This command created following errors which i am not sure how its can be solved.
dev@dev-server:~$ sudo docker run -v /home/dev/Desktop/cloud-docker:/var/www/owncloud -p 8080:8080 owncloud/server
Creating volume folders…
Creating hook folders…
Writing config file…
Fixing base perms…
Fixing data perms…
Fixing hook perms…
Upgrading server database…
Could not open input file: /var/www/owncloud/occ
Touching log file…
dpkg: error: --compare-versions takes three arguments:
Type dpkg --help for help about installing and deinstalling packages [*];
Use ‘apt’ or ‘aptitude’ for user-friendly package management;
Type dpkg -Dhelp for a list of dpkg debug flag values;
Type dpkg --force-help for a list of forcing options;
Type dpkg-deb --help for help about manipulating *.deb files;
Options marked [*] produce a lot of output - pipe it through ‘less’ or ‘more’ !
Writing objectstore config…
Writing php config…
dpkg: error: --compare-versions takes three arguments:
Type dpkg --help for help about installing and deinstalling packages [*];
Use ‘apt’ or ‘aptitude’ for user-friendly package management;
Type dpkg -Dhelp for a list of dpkg debug flag values;
Type dpkg --force-help for a list of forcing options;
Type dpkg-deb --help for help about manipulating *.deb files;
Options marked [*] produce a lot of output - pipe it through ‘less’ or ‘more’ !
Writing apache config…
Enabling cron background…
Could not open input file: /var/www/owncloud/occ
can anyone help with this issue or can you guide how can i mount the /var/www/owncloud from container to the host pc?