ownCloud does not connect to server after restart

reported_app_bug
client-development

#1

Hi,

we are using ownCloud in our business. The thing is the client does not connect to the server after restart. Everytime I have to delete my account and add it again. Then everything goes smooth until I restart. This is really frustrating.

We tried this on ubuntu and kubuntu same result.
Can someone tell me why it does not work or fix it?

Greetz


#2

Hey @franz.schwerdtmann! By the behavior you describe it's very likely that your Gnome keyring or dbus services are not properly running on your system.

Which version of the owncloud client are you using? Have you followed the instructions on the installation repository and did you see any errors/warnings during the installation process?

If you can enable the client logs on the buggy restart, we can probably find out what's going on in there.

Cheers!


#3

Okay, I have Ubuntu 16.04 and installed oC by sudo apt-get install owncloud-client and had some 2.1 version installed.
Now I tried to follow the instructions but have some authentication issues when updating.

I used sudo apt-get purge owncloud-client to remove it.
then I added the Repo to my apt-list.
I tried to update but had some broken dependencies. I used sudo apt autoremove and sudo apt-get install -f
After that I was able to update again.

Now I am back at the start:
https://pastebin.com/SfNjkuYs

and still cant fix it.


#4

@franz.schwerdtmann take a look at https://github.com/owncloud/client/issues/1590#issuecomment-329703705 it's very likely that your SO is missing a password manager and therefore owncloud is unable to store it for further executions.


#5

I use keepass so far. But dont now how I could integrate oC.


#6

I meant something closer to the OS so the client can store your account credentials; not as high-level as keepass or 1password. If you're using Ubuntu, I'd try to install libgnome-keyring and check the behavior afterwards.