Owncloud Error - Certificates

hosting

#1

Hello

When connecting to my owncloud Web page, and following an invalid HTTPS certificate notifications, I tried to update it, I followed the attached procedure: http://www.coursnet.com/2014/11/certificat-auto-signe-linux.html

Procedure that I tried to follow at best. Some steps that have failed to succeed.

I passed the following commands:
1 °) OpenSSL Genrsa-out server. Key 1024
2 °) OpenSSL req-New-key server. Key-out server. CSR
3 °) OpenSSL X509-req-Days 365-in server. CSR-Signkey server. Key-out server. CRT
4 °) Restarting the server

Since I restarted the server I have the following message:

Internal server error
The server has encountered an internal error and is unable to execute your query.
Please contact the server administrator if this error appears several times. Please attach the technical details to your report.
The server log file can provide more information.

Having fairly low knowledge on the certificate part, I would like to have some help on that part, because I am sure it comes from the amendment I just made.
Could someone help me solve the problem by giving me leads or by remotely assisting me?

Thanks in advance,

Nice day


#2

anything in the server logs? data/owncloud.log


#3

I don’t see the owncloud.log on server, i am searching if i can find this log.


#4

Once again: data/owncloud.log

You can download it from the admin panel, section General.


#5

i cant login on owncloud because have error message on web interface.
Juste the server is avaible. can you tell me the exact path?
Because in / var / logs I dont have an owncloud.log file


#6

In case your owncloud directory is named owncloud

/var/log/www/owncloud/data/owncloud.log

or

/var/log/www/html/owncloud/data/owncloud.log


#7

U can see all logs i can see on my server.
Dont see folders owncloud …


#8

You should consider to fill out the issue template that is presented when opening a new topic. Otherwise we don’t have all relevant information about your installation an cannot help further.


#9

Hey, i think there is a “log” too much between /var/ and /www/ so the links could be:

/var/www/owncloud/data/owncloud.log

or

/var/www/html/owncloud/data/owncloud.log

#10

YES, my fault. Sorry. I was somewhat confused…


#11

U can find error message in owncloud.log after update certificates :

{“reqId”:“kcGf0ctaQUVzqJoCZTxz”,“remoteAddr”:“X.X.X.X”,“app”:“remote”,“message”:“Failed to connect to the database: An exception occured in driver: SQLSTATE[HY000] [2002] No such file or directory”,“level”:4,“time”:“2018-08-06T10:20:44+00:00”,“method”:“GET”,“url”:"/status.php"}


#12

Do you have an idea or a track to communicate to me?


#13

Is your database up and running?