Owncloud instalation on ubuntu 20

Hello,

Following the instruction on other posts, i was advise to install the ownclou server ona ubuntu 18 our 20, since is no longer supported on 14 and 16.

Well, now i have anote issue:
I tryng to follow ths insttalation instruction and it look there are no php release candidate to ubuntu 20.

Package php-smbclient is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package ‘libapache2-mod-php7.2’ has no installation candidate
E: Unable to locate package php7.2-common
E: Unable to locate package php7.2-curl
E: Unable to locate package php7.2-gd
E: Unable to locate package php7.2-imap
E: Unable to locate package php7.2-intl
E: Unable to locate package php7.2-json
E: Unable to locate package php7.2-ldap
E: Unable to locate package php7.2-mbstring
E: Unable to locate package php7.2-mysql
E: Unable to locate package php7.2-pgsql
E: Package ‘php-smbclient’ has no installation candidate
E: Unable to locate package php7.2-sqlite3
E: Unable to locate package php7.2-xml
E: Unable to locate package php7.2-zip

Any ideas?

Unfortunately you did not tell how you tried to install ownCloud.

Did you follow the official documentation at https://doc.owncloud.com/server/10.5/admin_manual/installation/ubuntu_18_04.html? There it states 18.04 but it is applicable for 20.04 as well.

In the above doc there is no explicit mention of php7.2 (which does not exist any longer on Ubuntu 20.04), so the php7.4 packages will be installed.

OR did you try to install ownCloud via repository? Did you make sure you are using the 20.04 repo? see https://download.owncloud.org/download/repositories/production/owncloud/ -> Ubuntu

Hi the server was installed sucefully with work instruction that you refer.

I have allready install teh ldap integration ans it works to, but when i set to work with ladps i’m geeting error

Have you tried the checkbox “Use StartTLS support”?
If the certificate installed on the LDAP server is self-signed you might have to import it with the occ security:certificates:import command:
https://doc.owncloud.com/server/admin_manual/configuration/server/occ_command.html#security

Yes
I try with tls option too

root@srv-ptp-cloud01:/etc/ssl/certs# occ security:certificates:import /etc/ssl/certs/EUROPE-Root-CA.crt

In Certificate.php line 62:

Certificate could not get parsed.

Double check the format of your file, it should look like this:

-----BEGIN CERTIFICATE-----
MIIEkTCCA3mgAwIBAgIERWtQVDANBgkqhkiG9w0BAQUFADCBsDELMAkGA1UEBhMC
[...]
-----END CERTIFICATE-----

Hi

I alredy check the certicate format and now i recevei in pem format and ti was imported sucefully but still have the some issue, i can share a screen with you with webex if you need to check anything.

Tank you.

Hello Analmeida,

Let me tell you that the package php-smbclient was removed from the offical repository, I had the same issue and I solved with this steps,

echo “deb http://ppa.launchpad.net/ondrej/php/ubuntu $(lsb_release -cs) main” | tee /etc/apt/sources.list.d/php.list

apt-key adv --recv-keys --keyserver hkps://keyserver.ubuntu.com:443 4F4EA0AAE5267A6C

apt update && apt install -y php-smbclient

Hi

This command is for debain, i’m using Ubuntu

Tabnks

Some error :cry:

Your bindDN does not look correct, sorry for not noticing that earlier, it should look either like:

  • cn=<username>,ou=<if the user is in an ou>,cn=<domain>,cn=<tld>
    or
  • <username>@<domain>.<tld>

Make sure you can concoct an ldapsearch command that results in successful output.

if you’re connecting with ldaps (and port 636) you shouldn’t have that checkbox marked.

1 Like