OwnCloud integration with OnlyOffice: Error while downloading the document file to be converted


#1

Hello,

I’m trying to set up integration between OwnCloud (version 10.0.9.5) and OnlyOffice using self-signed certificates.

Added next string in the config.php:
‘onlyoffice’ => array ( ‘verify_peer_off’ => TRUE )

But I receive next error entering ip address of the OnlyOffice server: Error when trying to connect (Bad Request or timeout error).

Do you have ideas how to fix it?


#2

How are you trying to reach the only office server? IP or domain name? http or https?

I would also look into the ownCloud log and the onlyoffice log file for more information


#3

Hello Dmitry,

trying both ways:

  1. IP - 192.168.XXX.XXX
  2. DNS name - onlyoffice.domain.local

Now I reinstall OnlyOffice and the error changed: Error when trying to connect (Error occurred in the document service: Error while downloading the document file to be converted.)

Error log:
{“reqId”:“W3bazVRBdY@L32dqt0VngAAAAAM”,“level”:1,“time”:“2018-08-17T14:25:21+00:00”,“remoteAddr”:“192.168.75.97”,“user”:“owncloud”,“app”:“onlyoffice”,“method”:“PUT”,“url”:"/index.php/apps/onlyoffice/ajax/settings",“message”:“Set default formats: {“csv”:“false”,“djvu”:“false”,“doc”:“false”,“docm”:“false”,“docx”:“true”,“dot”:“false”,“dotm”:“false”,“dotx”:“false”,“epub”:“false”,“fodp”:“false”,“fods”:“false”,“fodt”:“false”,“htm”:“false”,“html”:“false”,“mht”:“false”,“odp”:“false”,“ods”:“false”,“odt”:“false”,“otp”:“false”,“ots”:“false”,“ott”:“false”,“pdf”:“false”,“pot”:“false”,“potm”:“false”,“potx”:“false”,“pps”:“false”,“ppsm”:“false”,“ppsx”:“true”,“ppt”:“false”,“pptm”:“false”,“pptx”:“true”,“rtf”:“false”,“txt”:“false”,“xls”:“false”,“xlsm”:“false”,“xlsx”:“true”,“xlt”:“false”,“xltm”:“false”,“xltx”:“false”,“xps”:“false”}”}
{“reqId”:“W3bazVRBdY@L32dqt0VngAAAAAM”,“level”:1,“time”:“2018-08-17T14:25:21+00:00”,“remoteAddr”:“192.168.75.97”,“user”:“owncloud”,“app”:“onlyoffice”,“method”:“PUT”,“url”:"/index.php/apps/onlyoffice/ajax/settings",“message”:“Set opening in a same tab: true”}
{“reqId”:“W3bbEsujBo4i3rslG43aKgAAAAk”,“level”:1,“time”:“2018-08-17T14:26:26+00:00”,“remoteAddr”:“192.168.75.97”,“user”:“owncloud”,“app”:“onlyoffice”,“method”:“PUT”,“url”:"/index.php/apps/onlyoffice/ajax/settings",“message”:“SetDocumentServerUrl: https://onlyoffice.domain.local/”}
{“reqId”:“W3bbEsujBo4i3rslG43aKgAAAAk”,“level”:1,“time”:“2018-08-17T14:26:26+00:00”,“remoteAddr”:“192.168.75.97”,“user”:“owncloud”,“app”:“onlyoffice”,“method”:“PUT”,“url”:"/index.php/apps/onlyoffice/ajax/settings",“message”:“SetDocumentServerInternalUrl: “}
{“reqId”:“W3bbEsujBo4i3rslG43aKgAAAAk”,“level”:1,“time”:“2018-08-17T14:26:26+00:00”,“remoteAddr”:“192.168.75.97”,“user”:“owncloud”,“app”:“onlyoffice”,“method”:“PUT”,“url”:”/index.php/apps/onlyoffice/ajax/settings”,“message”:“SetStorageUrl: “}
{“reqId”:“W3bbEsujBo4i3rslG43aKgAAAAk”,“level”:1,“time”:“2018-08-17T14:26:26+00:00”,“remoteAddr”:“192.168.75.97”,“user”:“owncloud”,“app”:“onlyoffice”,“method”:“PUT”,“url”:”/index.php/apps/onlyoffice/ajax/settings”,“message”:“Clear secret key”}
{“reqId”:“W3bbEsujBo4i3rslG43aKgAAAAk”,“level”:3,“time”:“2018-08-17T14:26:31+00:00”,“remoteAddr”:“192.168.75.97”,“user”:“owncloud”,“app”:“onlyoffice”,“method”:“PUT”,“url”:"/index.php/apps/onlyoffice/ajax/settings",“message”:“GetConvertedUri on check error: Error occurred in the document service: Error while downloading the document file to be converted.”}


#4

Find solution here: https://github.com/ONLYOFFICE/onlyoffice-owncloud/issues/181

"When you use self-signed certificates they should be added to ca-certificate bundle of the OS of both servers (the one you use on Nextcloud should be added to the server with ONLYOFFICE Document Server and vice versa). The problem is that the certificate of Nextcloud should be also added to nodejs ca-certificate bundle, so the Document Server can verify it. But it is impossible for nodejs version 6, which is required for the Document Server at the moment.

We are working on the possibility to install Document Server with the later versions of nodejs, where it is possible to add self-signed certificates.

As a temporary solution you can disable verification of the certs by the Document Server. It should help. Please change the value of the parameter “rejectUnauthorized”: from true to false in /etc/onlyoffice/documentserver/default.json. After that restart all the services of the Document Server."