Owncloud+Nginx file upload


#1

Hi,
I am using latest OwnCloud 9.1.3 and Nginx web server. Everything works very well, but I have little trouble with uploading large files. My limit for file size is 2GB. When I start upload let say 1GB file, it starts continuously uploading. But at the end, file progress stuck on 99% for a few minutes.
I explore, what happened in system and found, that Nginx saving uploaded files to the own cache folder and after this copy the file to the right location (owncloud/data/userprofile/files/*). Is it some possibility how to turn off the upload cache?

Thank you


#2

See https://doc.owncloud.org/server/latest/admin_manual/configuration_files/big_file_upload_configuration.html#configuring-your-web-server

You probably need to set fastcgi_request_buffering off; in your nginx config.


#3

I read this document before and tried this settings. Unfortunately didn't work. Nginx still use upload cache for every file uploaded via web interface.


#4

Mhhh, then maybe get in touch with the support of nginx listed here: https://www.nginx.com/support/

They might have more knowledge about the configuration of nginx and how to configure it in a way that it doesn't show this issue.


#5

Good point, I will try nginx support and we will see.
I hope, that they didn't say, that is problem with OwnCloud.


#6

Unfortunately, nginx support says, that is problem with OwnCloud, it is like magic circle :smile:
Does anybody use nginx like web server for owncloud?