Owncloud not connect with AD - Samba 4

ldap
9.1.x

#1

Hi everyone, how are you?

I'm trying to connect to Samba 4 to perform the integration with AD by viewing this tutorial: https://vorkbaard.nl/adding-owncloud-8-to-active-directory-2012-r2-part-4-connecting-to -active-directory /

But I'm having trouble making the connection. The owncloud.log tells me the following:

{"reqId":"3RyFKEnQBskWM7JwR1Ju","remoteAddr":"10.123.50.82","app":"user_ldap","message":"Configuration Error (prefix ): No LDAP Login Filter given!","level":2,"time":"2017-03-29T21:20:13+00:00","method":"POST","url":"\/owncloud\/index.php\/apps\/user_ldap\/ajax\/wizard.php","user":"administrador"}
{"reqId":"3RyFKEnQBskWM7JwR1Ju","remoteAddr":"10.123.50.82","app":"user_ldap","message":"Configuration Error (prefix ): login filter does not contain %uid place holder.","level":2,"time":"2017-03-29T21:20:13+00:00","method":"POST","url":"\/owncloud\/index.php\/apps\/user_ldap\/ajax\/wizard.php","user":"administrador"}

At no time does the connection signal turn green.

Has anyone gone through this? Would you help me?

Thank you very much!


#2

It seems like AD was case sensitive on the filter setups. So things like the capital U for users was important.


#3

Hey Leeo,

Did you enter the valid information for the AD integration?? can you double check and if possibkle can you palce the screenshots


#4

Hello guys!

Thanks for the answers.

I will send some images of my configuration:


#5

More one:

Is any other image interesting?


#6

I solved my problem!!! :slight_smile:

I inserted the following parameter into smb.conf:

"Ldap server require strong auth = no"

Thank you!!