Owncloud nyt syncing on my Drobo5N

8.2.x
update
help

#1

Hi

I am a total newbie on owncloud, so I hope this is the right category....

Installed it a while ago on my Drobo5N (nas) and all was well, but now it is not syncing anymore. If I open the app I get a note that there is an upgrade 8.2.7.
I am currently on 8.2.0 on my Drobo. In the DroboApp interface there is no updates available.

My questions are:

Do I need to upgrade to get the sync to work?
If yes - how do I upgrade outside of the DroboApps interface? (from a PC)
Is there a way to rebuild/reset/resync my files?

Regards,
Jesper


#2

Hi,

a rule of thumb is to always use at least the latest available version of your major version (8.2.7 for 8.2.x). Depending how you did the installation you can choose one of the upgrade/update variant described here:

https://doc.owncloud.org/server/9.1/admin_manual/maintenance/upgrade.html


#3

I have seen that list but I have no clue of which way I should use since I installed the ownCloud App via the Drobo Dashboard.

I can see the folder of the installed files, would it be possible to just overwrite the files with some newer versions?

I have no clue of which operating system the Drobo uses either....


#4

Hi,

if this app is provided by this Drobo Dashboard its probably the best to ask the provider of this package how a update should be done.

You should also make them aware that oC 8.2.0 is outdated and has quite some public known security vulnerabilities listed here:

https://owncloud.org/security/advisories/

If they can't manage to provide up2date packages they shouldn't provide them at all.


#5

I tried to use the updater via the admin web interface. But I get this error:

"Unable to move /mnt/DroboFS/Shares/DroboApps/owncloud/app/_oc-upgrade/8.2.7/core/resources to /mnt/DroboFS/Shares/DroboApps/owncloud/app/resources"

I think I might need to run this code to set permissions:

!/bin/bash

Sets permissions of the owncloud instance for updating

ocpath='/var/www/owncloud'
htuser='www-data'
htgroup='www-data'

chown -R ${htuser}:${htgroup} ${ocpath}

but how do I run it? - from a command prompt in windows?


#6

Hi,

thats a known bug in the old variant of the updater app which can be solved by doing the following edit:

Open /path/to/owncloud/apps/updater/lib/location/core.php

Change:

$list = $fullList['8.1'];

to:

$list = $fullList['8.2'];

Ref: https://github.com/owncloud/updater/pull/192/files

You still should contact them that they don't distribute such outdated oC versions. :slight_smile: