Owncloud redirect - some issues

9.1.x
help
webserver_issue

#1

Hi guys,

Yesterday I installed + setup Owncloud into my Ubuntu server. I also put SSL + and redirect from https://domain.tld:port/owncloud to https://subdomain.domain.tld:port. It seems everything is OK, but I have two problems:

Expected behaviour
1.- If I try to enter to the assigned IP in my local network (192.168.x.x), it obviously does not work. I would like to know how to setup the server to allow me to enter from local network too.

2.- A second problem is that I can enter to my domain using https://subdomain.domain.tld:port or https://subdomain.domain.tld:port/owncloud, so I would like to "delete" the "/owncloud" part and just enter via https://subdomain.domain.tld:port

Server configuration
Operating system: Ubuntu server 16.04
Web server: Apache
Database: MySQL
PHP version: 7
ownCloud version (see ownCloud admin page): ownCloud 9.1.0 (stable)
Updated from an older ownCloud or fresh install: no
ownCloud log (data/owncloud.log, see https://central.owncloud.org/t/how-to-find-webserver-or-oc-logfile-enable-php-logfile/808): no necessary

Special configuration (external storage, external authentication, reverse proxy, server-side-encryption): SSL?

Integrity status for oC9+

No errors have been found.

I think it should be easy but I cannot find a solution for my issues. Could someone help me?

Thanks a lot!


#2

Hi,

this is a networking/webserver issue not related to ownCloud at all. For this you might get better help on a community like http://www.apachelounge.com/

See https://doc.owncloud.org/server/9.1/admin_manual/installation/changing_the_web_route.html


#3

Hi RealRancor,

Thanks for your amazing quick reply.

1.- I will go to Apache forums, thanks for suggestion!

2.- It works like a charm, thanks a lot. When I put /owncloud in URL it says:

Not Found

The requested URL /owncloud/ was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

Apache/2.4.18 (Ubuntu) Server at subd.domain.tld Port XXX

It is basically what I want, but could it be possible to "show" a different error message? Just to do not show the Apache version and put something like a picture. Maybe changing the 404.php template?

Thanks for your help!

Best regards

Edit: Maybe it is an Apache question too...


#4

Hi,

thats also a webserver configuration thing which you could ask at such an Apache forums like mentioned above.


#5

Okay, I'll do it. Thanks for your help!