Owncloud startup problem

Good morning everyone,
when on the browser I type the IP address / owncloud I get this error:
“Safari cannot open the page: https: // IP / owncloud. Error:” load cannot follow more than 20 redirections ".

Hello Nemo,

You need to get a real DNS :slight_smile:

I had the same error when I tried free DNS.

This is but merely a stab in the dark, for real help please fill out the template or provide more info about your setup / issue.

Best Regards

Dmitry

Currently I have not set up any free DNS … I only installed openssl …
I will try to reinstall openssl by activating a free DNS first …
If you tell me what I could post to help you the most

Can you post the documentation you used to set up your ownCloud? The error message can indicate a redirection loop as well, so your Apache vHost configuration might help as well.

for apache and the database i used these commands:

sudo apt install apache2 apache2-utils

sudo systemctl start apache2

sudo systemctl enable apache2

sudo apt install mariadb-server mariadb-client

sudo apt install mysql-server mysql-client

sudo systemctl start mariadb

sudo systemctl enable mariadb

sudo mysql_secure_installation

Blockquote

For sslcertificate:

sudo openssl genrsa -out server.key 4096
sudo openssl req -new -key server.key -out server.csr

there will be some entries to fill in, but the most important one is COMMON NAME, which I have pointed to my DynDNS hostname for remote access:

sudo openssl x509 -req -days 1825 -in server.csr -signkey server.key -out server.crt -sha256
sudo chmod 400 server.key
sudo mv server.key /root/server.key
sudo mv server.crt /root/server.crt
sudo cp /etc/apache2/sites-available/000-default.conf /etc/apache2/sites-available/000-default.conf_bak
sudo nano /etc/apache2/sites-available/000-default.conf

Below the DocumentRoot line we write:

Permanent redirect / https: // myIP /

Then again:

sudo nano /etc/apache2/sites-available/default-ssl.conf

and edit the entries, SSLCertificateFile, SSLCertificateKeyFile, as below:

SSLCertificateFile /root/server.crt
SSLCertificateKeyFile /root/server.key

At the end of this file we add:

Header always set Strict-Transport-Security "max-age = 15552000; includeSubDoma $

enable encryption:
sudo a2ensite default-ssl.conf
sudo service apache2 reload
sudo a2enmod ssl
sudo service apache2 restart

Blockquote