OwnCloud stopped working after moving http-root

Hey,

I’m using Apache 2 and Virtual Hosts… Today i added a new domain an changed the directory
of my main domain from /var/www/html/ to /var/www/domain.com/

My owncloud stopped working and i changed everything back but it didn’t solve the problem…
It would be very kind if anyone has an idea where the problem is.

Logs: https://pastebin.com/sgiyUDGp

There are too many links in the log files for a new user.

Thanks!

From the logs I see you started an upgrade which did not succeed, because the app files_videoplayer had not been disabled.

Try this in the ownCloud directory on your shell:
sudo -u www-data php occ app:disable files_videoplayer
sudo -u www-data php occ upgrade

Also make sure, that the ownCloud directory is read- and writable for user www-data

Then it could be possible your ownCloud is up again.

In the apache.conf you show, I read /var/www/owncloud as document root. Didn’t you mention /var/www/domain.com ? If this is the case, you’ll have to fix the apache confs as well.

I’d recommend to read the docs at https://doc.owncloud.com/server/10.3/admin_manual/installation/manual_installation.html where basically all necessary setup steps are described.

2 Likes

Thank you very much!

I’ve again edited my vhosts file so they point on /var/www/domain.com/.
Then I edited the owncloud.conf (vhost file of the apache) so that the document root points to “/var/www/domain.com”.
After that I disabled the video player and started the update as you told me. It worked without an error and my ownCloud is up again!

1 Like