Owncloud sync stops, webportal extremly slow, update not working

help

#1

Hello everyone. I have multiple issues with my owncloud configuration during the last days and do not have any idea how to solve that.

I use an owncloud installation (version 8.2.2) on a hosted webserver. This is synchronized with my computers at home as well as my work computer (all Windows 10). During the last days my auto sync stopped and I got a message that my storage capacity has been exceeded. First I emptied my files_trashbin folder and the files_versions folder as I found lots of double entries and old file parts. Finally, the storage usage decreased to just 50%.

However, the sync to the computers is in waiting state because of a request timeout. When trying to log into the web interface it is really slow - needs me about 1 min or more to do the login. The current owncloud version is quite old and there was displayed that a new stable version is ready for update. However, the update doesn't work due to a server issue. The short message is:

Undefined index: HTTP_USER_AGENT at /home/perolind/public_html/owncloud/lib/private/appframework/http/request.php#678

Another (former) message was, that the folder public_html/owncloud/lib/private/helper.php ... ist not empty (I do not understand these points).

Does anyone have an idea what could be the reason for this behavior? I just tried to download the lof file but this did not work due to request timeout. I would be glad, if you could give me a hint or tell me, what data you need addionally for an answer.

Thanks a lot in advance!


#2

I think you already know it, but you should update to a current ownCloud version. 8.2 is out of life.


#3

Yes, this was one of my first ideas. However, I am not able to do the update as it always ends with an error. Do you have any idea for a workaround?


#4

How did you try to update?

What error occurs?

To what Version did you try to update?


#5

I logged into my owncloud web interface as admin and tried to use the update function in the admin panel there. Currently I cannot look what update version it has been (I think I remember 8.2.11?). Cannot log into my owncloud right now as I get this message:

Resource Limit Is Reached
The website is temporarily unable to service your request as it exceeded resource limit. Please try again later.

Checked my server and realized that something is filling up my webspace again (over 14 GB in the last 3 hours). Currently I have 37/50 GB of storage used. I stopped the owncloud sync on all active machines first. The main data has been filled in a hidden folder .cagefs/tmp and I do not know why. Can I empty this folder directly?

The error messages I wrote in my first post. Or do you need some other messages?


#6

You can upgrade your owncloud manualy without access to the web interface.

https://doc.owncloud.com/server/10.0/admin_manual/release_notes.html#changes-in-10-0-3

If you upgrade to 8.2.11 you can upgrade with a single upgrade to 10.0.7 - the current owncloud.

Here is how to upgrade manually:

https://doc.owncloud.com/server/10.0/admin_manual/maintenance/manual_upgrade.html

Edit: I don't know what cagefs is either, or what is stored there.

found this with google seach:

https://forum.owncloud.org/viewtopic.php?t=25561

also this:


#7

Hello dmitry,

thanks for your help. Unfortunately, I am not that bright lamp in using command line configuration on a server. Currently, there is enough space on the server but the automatical update still does not work. So I will uninstall my current version and set up a new owncloud. Thi should hopefully solve all issues.

Thanks a lot for your hints and I hope to handle everything well.

Best regards!