OWNCLOUD_TRUSTED_DOMAINS not working

Steps to reproduce

  1. Setup owncloud with docker following official instructions
  2. Explicitly specify OWNCLOUD_TRUSTED_DOMAINS=localhost,192.168.xxx.xxx, try to go on with that machine and it doesn’t work
  3. Try the same thing, but with quotes: OWNCLOUD_TRUSTED_DOMAINS=“localhost,192.168.xxx.xxx”, still doesn’t work
  4. Run docker volume prune -a and try both again, does not work
  5. Go to settings > security > add domain, still doesn’t work

Expected behaviour

Not receive " You are accessing the server through an untrusted domain.
Please contact your administrator. If you are an administrator of this instance, configure the “trusted_domains” setting in config/config.php. An example configuration is provided in config/config.sample.php or at the [documentation]." and be able to access files on another device on the same network.

Actual behaviour

Not able to do that. Keep getting " You are accessing the server through an untrusted domain.
Please contact your administrator. If you are an administrator of this instance, configure the “trusted_domains” setting in config/config.php. An example configuration is provided in config/config.sample.php or at the [documentation]."

Server configuration

Operating system:
MacOS M1 Ventura13.5.2

Database: MySQL

ownCloud version: (see ownCloud admin page) 10.14.0.3

**Updated from an older ownCloud or fresh install:**No

Where did you install ownCloud from:https :// github. com/ owncloud- docker/ server

Signing status (ownCloud 9.0 and above):
No errors have been found

The content of config/config.php:

...
        "trusted_domains": [
            "localhost"
        ],
...

List of activated apps:

Are you using external storage, if yes which one: local/smb/sftp/… No

Are you using encryption: No

Are you using an external user-backend, if yes which one: No

Client configuration

Browser: Google Chrome

Operating system: Windows 10

Hey,

maybe 192.168.xxx.xxx is not the actual IP address of the Docker installation / system? Could it be possible that you have configured a wrong IP here, for example the IP of your desktop system?

2 Likes

Hey,
you are right, it was the wrong IP. Thanks for the reply!

1 Like