Owncloud ubuntu appliance has broken php5-libsmbclient


#1

Please help us by providing the following info. Before posting please also check the pinned "Known issues" threads and make sure that you're running the latest available version for your oC release: https://owncloud.org/changelog/

Steps to reproduce
1.try and use SMB in oc appliance
2.
3.

Expected behaviour
Tell us what should happen - smb shares should work out the box because php5-libsmbclient is installed

Actual behaviour
Tell us what happens instead: error "Note: "smbclient" is not installed. Mounting of SMB / CIFS, SMB / CIFS using OC login is not possible. Please ask your system administrator to install it."

Note that installing the "libsmbclient" from apt-get means the error goes away and you can configure the SMB shares but they dont work.

Server configuration

FRESH install from ubuntu 14 appliance .raw (VM image). No config changes made.

ownCloud log (data/owncloud.log)

Please paste possible errors in the following code block, see https://central.owncloud.org/t/how-to-find-webserver-or-oc-logfile-enable-php-logfile/808 for more info

Integrity status for oC9+

Login as admin user into your ownCloud and access
http://example.com/index.php/settings/integrity/failed
paste the results here.

#2

Hi,

unfortunately issues like this won't get noticed and fixed in here. Please always report issues to the code of ownCloud or stuff like the appliance to the github bugtracker. The issue tracker for the appliance is available at [1].

[1]


#3

Thanks for your response. To be honest I'm pretty new here. I understand what you're saying but this issue is really up to the admins at owncloud to fix on their own. The result here is that I've destroyed the VM and I'm no longer using it. I would very much like to use it but I'm not sure how to tell when this issue is fixed in the appliance.

From looking at the appliance, it appears that someone had tried to install the php libsmbclient module but given up someway through. In all honesty it looks like they had trouble with the package during install; just like I had myself when I tried to build this onto a RHEL7 system.


#4

Sure, but they won't notice this in here so your current post is mostly useless if its not reported to the bugtrackers. :confused:


#5

That's a shame then :slight_smile:
I'll try and post in the link you sent. thanks again


#6

Hey tony!
Thanks for you report!

SMB shares should really work in the community appliance too.
if the libsmbclient package is missing, then you may have already discovered the cause of the issue.
I am a bit worried that you say, it still does not work after installing libsmbclient.

Is there an error message when you configure shares then?


#7

Thanks for your polite response.

It's odd because after installing the smbclient package I was able to configure the smb shares and they went green as though successfully connected. When I logged in as the end user and clicked on the share, it simply refreshed the page. A yellow toast-like error did pop up. I checked the error log and the error was that the server hostname was not reachable. This error also showed when i configured the smb share with IP address instead of hostname.
I do have another working owncloud but it's running red hat php5.4. The smb shares are working there, so I am confident the configuration is ok. What I prefer to do is to use the logged in OC credentials to map the share, so the share maps upon user login. But when I originally tried to do this, the share remains red in the user portal. Hence why I entered the credentials manually in the admin page and witnessed the share showing a green status icon. But as explained, this appears the share is working but when you click on it the page simply refreshes.

Apologies I don't have the logs saved off-box. It would be great if someone else could verify this too. I took a volume snapshot before trying to fix the issue myself so i can revert to the out-of-box condition tomorrow and then reply with logs after a reproduce. But basically as I see it there are two problems:
1. libsmbclient is not installed (not sure if this is required as well as the below at point 2)
2. php5-libsmbclient is not installed properly

For point 2, there is a symlink at /etc/php5/modules and the destination file doesn't exist. It's missing the libsmbclient.ini file which basically mentions to apache/php which .so module to load. I did a "find / -name smb" and not very much came back. I did find an empty libsmbclient file which may have been the module but I'm not sure if this was caused by me trying to fix it. I didn't find any variation of smb*.so file.

Finally, when you install the libsmbclient there is no error when you configure the shares. In fact they come up as successful / green. But they are not functional from the user page in OC.

All I want from OC is smb shares and LDAP authentication :slight_smile: :slight_smile: I literally couldnt find all the packages required from a repo ANYWHERE, either from Red Hat themselves or a repo applicable to CentOS. I admittedly did not look to build my own ubuntu system but decided to use the appliance. Unfortunately, same issue it seems. But at least APCu is working and the response from OC in the ubuntu appliance is noticeably faster than the somewhat messy POC I built. :slight_smile:


#8

I've installed the latest OVA image.
Ubuntu_14.04-owncloud-9.1.4-1.1-201702081724.ova.zip
and found that libsmbclient is correctly installed.

sudo apt-get install libsmbclient
Reading package listrs... Done
Building dependency tree
Reading state information... Done
libsmbclient is already the newest version.
libsmbclient set to manually installed.

Which image did you try?


#9

Sorry what I done was "apt-get install -q -y smbclient" so I was incorrect, it was smbclient not libsmbclient (sorry I've spent all day on this and it's a blur now).

BUT before trying that, please try to configure an smb share, you'll see that it says "smbclient is not installed" and there is no option to select smb as the storage type to configure it.


#10

This should be reported to [1] if the libsmbclient is installed and loaded correclty in your PHP environment.

[1]


#11

I did report it in the first github link but it's a pre-built appliance. I shouldnt need to check if anything is loaded :slight_smile:


#12

The message is not about the appliance but about the message itself :slight_smile:


#13

I think this is where my technical expertise ends. I'm a network engineer :joy:


#14

No worries. Details are being tracked in https://github.com/owncloud/vm/issues/54
I am pushing a rebuild of the appliance out right now. Please test.

Ubuntu_14.04-owncloud-9.1.4-2.1-201703101635


#15

Oh, so this was indeed an issue only at the appliance? Then my previous comment in [1] is void.

[1]


#16

Thanks for the rebuild, looks good now :slight_smile:
I do have an issue where I keep being logged out and can't sign back in. I'm using LDAP against MSAD Windows 2012. The only thing different in this set up is I set my AD account to be an admin in addition to the "admin" user within OC. When I did manage to log in with my AD account I was no longer an admin and the admin account could not log in. I reset the admin password and logged in as admin and some of the LDAP config and other AD / group config was missing but the AD config itself was there still. I put the config back in again but the same happened again so I've left it for now. I'll take myself off admin and see if the issue goes away. :slight_smile:


#17

Tony, thanks for confirming that the updated appliance did the trick.
Hard to tell what is going on with your AD admin accounts there. Seems like a diferent (and very unfamilliar) issue to me.