Owncloud Updater: cURL error 7: Failed to connect to localhost port 443: Connection refused

Then i’m calling the Updater for the version 10.2.1 i get the error:

cURL error 7: Failed to connect to localhost port 443: Connection refused

My owncloud installation does not uses localhost as url anywhere. It’s located under a public (sub-) domain with LetsEncrypt SSL certificate.

Server configuration

Web server: Shared

Database: MySQL 5.6.43

PHP version: 7.2

ownCloud version: 10.1.0.4

The content of config/config.php:
config_report_20190710.json.txt (210.9 KB)

Are you using encryption: no

Web server error log

[Wed Jul 10 08:37:31 2019] [authz_core:error] [pid 24574] [client 95.222.31.0] [host xxxxxxxxx] AH01630: client denied by server configuration: /is/htdocs/wp1051993_AOB8H30P2T/www/owncloud/owncloud/data/htaccesstest.txt

If you are using the Virtual Box Appliance, then log into Univention and update from Software Update.
Will be listed under “App Center Updates”

After updating, mine shows this version in owncloud. Log in as admin, go to settings then Admin Section -> General. You should see Updater “Your version is up to date” and System status version 10.2.1.4

He is saying that he is using a shared web host, not the appliance, so I don’t think this applies here.

Shared Webservers and ownCloud usually don’t go well together because you have to have access to the command line and be able to run occ commands as webserver-user, otherwise it is broken by design.

Not sure why the updater needs to connect on port 443 localhost, but I would recommend logging into your webserver and try to run a curl command doing exactly that. If it doesn’t work contact your hosting provider and ask them for help. If you can’t run curl locally I would recommend to move to another webhoster where you can.

Thanks and yes, the first answer does not help me.

You mean, that i should call curl https://xxx.xxx.xx/updater/, or which url should i call?

The reason, why i use a shared hoster? Because it is much cheaper for a private instance :wink: There is no reason for me, why the updater should not work on a shared host - especially as it worked the last time. So there might be a reason in the code, why localhost:443 is called, although the domain is completly not localhost.

1 Like

The updater would have to NOT call localhost on https but your own domain. Public IP address wouldn’t work either, because the shared host can only route the request to the correct virtual host based on the domain.

You can get a root VPS for about 2€ a month, most shared hosters I have seen cost at least as much or are more expensive than that…

Okay, so you say the behaviour of my installation is not correct, as it should call the public domain instead of localhost. Any suggestion to get this fixed - without ssh:curl and without complete new upload?

2€ monthly for root - im curious, where? Want to check the conditions. :wink:

No, that’s not what I meant. Sorry I should have been more clear. I don’t know whether the behavior is right or wrong. I’m just saying that it won’t work like that on shared hosting, because by design you can’t connect to localhost and get your ownCloud instance.

I’ve had a quick search in the updater code for localhost and found that at some point it is trying to fall back to localhost because it wasn’t able to connect to anything else.

So I would recommend to double check your trusted domains and make sure they are correct and don’t include localhost in your config.php.

Regarding your hosting question, I decided to move this discussion to a different topic: