ownCloud upgrade.disable-web working?

Hello everyone,

I’m running several instances of ownCloud (actually 10.2.0) that I upgrade with automation scripts, thus I don’t want my ownCloud to be uptaded through the web interface. I set the upgrade.disable-web parameter to true in the config.php of every ownCloud, but once I’m in the admin page I have the update as you might see in my screenshot.

Worse, if I click on it, it will do the update.

Is it possible to really block the update from the web ?

Thanks.

As a “hotfix” I set updater.server.url to 127.0.0.1 so when you try to start the upgrade it says “No updates found online.”, I’d rather prefer the upgrade.disable-web to work fine :grin:

1 Like

Afaik the config setting upgrade.disable-web only affects the ownCloud frontend, when e.g. an app must be upgraded, the upgrade button is not shown.

You might want to disable and remove the app updatenotification, which provides the admin settings and the updater there.

I hope, this is, what you require :slight_smile:

Hello @cortho

thanks for your answer actually here is my full configuration to bypass ownCloud’s upgrade and apps upgrade, I added the official comments to explain their purpose.

/**
 * Disable the web based updater
 */
  'upgrade.disable-web' => true,
/**
 * Automatic update of market apps, set to "false" to disable.
 */
  'upgrade.automatic-app-update' => false,
/**
 * Check if ownCloud is up-to-date and shows a notification if a new version is
 * available. This option is only applicable to ownCloud core. It is not
 * applicable to app updates.
 */
  'updatechecker' => false,
/**
 * URL that ownCloud should use to look for updates
 */
  'updater.server.url' => '127.0.0.1' // I add this one now since upgrade.disable-web does not work

So, to sum up the main problem here was that even with ‘upgrade.disable-web’ => true I would have the “upgrade button” in the admin page (but not the notification since I have ‘updatechecker’ => false). I add now ‘updater.server.url’ => ‘127.0.0.1’ so even if it shows the button, once you click, it answers very fast “No updates found online.” and I’m sure to keep a full automated control. I’m not very “proud” of that but at least it’s a dirtfix and I don’t screw the overall speed.

I already don’t use updatenotification app :wink:

Anyway the main problem here is that ‘upgrade.disable-web’ => true should never show the upgrade button in the admin.

Thanks.

I agree. Maybe this was overlooked by the app devs. I filed an issue at

2 Likes

Hello @cortho
it’s kind, thanks !