Owncloud Windows client does NOT SYNC folders when folder name starts with a dot

Steps to reproduce

  1. in local synced tree / space / file system create or rename a folder as .resource
  2. owncloud’s windows client will sync it to the sync target
  3. a few moments later, owncloud’s windows client will launch a sync again after which the folder will no longer be found on the server and it will no longer have a sync status on the windows explorer

Expected behaviour

In above steps list, The folder should not be deleted and step 3 should not happen

Actual behaviour

The folder is just deleted on the server. On the client (windows), the folder is no longer synced, unless I rename it, in which case the owncloud client tries to sync it, ending in the same results.

As a result of this behaviour, Joplin app on mobile devices is no longer working, refuses to sync.

Server configuration

Operating system:
raspbian bullseye
Linux 5253 6.1.21-v8+ #1642 SMP PREEMPT Mon Apr 3 17:24:16 BST 2023 aarch64

Web server:
Apache/2.4.59 (Debian)

10.5.23-MariaDB-0+deb11u1 Debian 11

PHP version:
PHP 7.4.33

ownCloud version: (see ownCloud admin page)
ownCloud 10.14.0 (stable)
windows client: version
using several iOS and Android clients as well

Updated from an older ownCloud or fresh install:
fresh install, several years ago

Signing status (ownCloud 9.0 and above):

No errors have been found.

The content of config/config.php:

Wow, that’s 8627 lines of text to review!

See this page where another Joplin user logged the same issue 2y ago, I’m happy to oblige if you are not able to reproduce:

github dot com slash laurent22 slash joplin slash issues slash 6273

List of activated apps:


Are you using external storage, if yes which one: local/smb/sftp/…

2 usb-based disks, mounted locally in raid 1

Are you using encryption: yes/no


Are you using an external user-backend, if yes which one: LDAP/ActiveDirectory/Webdav/…


Here is a screenshot of a synced folder in my windows explorer on the machine where I noticed and reproduced the issue.

Note the absence of sync icon for folder names starting with a dot.

Screenshot 2024-05-31 183130

Folders that begin with a dot are considered hidden on Linux and are not synced by the ownCloud client by default. Did you explicitly enable the sync of such folders?

Not sure where on my post does it say that I am using Linux for the owncloud client?
I have even included a screenshot of my client machine using windows.

OK so above comment gave me a lead: I looked at the settings of the windows client, activated “sync hidden files” and now it works.

The issue is then:

  1. On the owncloud client (windows version)
  2. Not on the server

TO DO FOR OWNCLOUD DEVELOPERS => Owncloud windows client developers should take into consideration that .folder files are NOT hidden files in Windows and therefore MUST BE SYNCED without having to activate above-mentioned option.

You miss the point about my mention Linux. Since you as a Windows user may not understand that dot files are hidden files is the reason I bought it up. It has nothing to do with the platform your client is using. It is to help you understand why the client behaves the way it does. Your ownCloud server is running Linux and the behavior about the dot files being considered hidden on Linux is relevant because the ownCloud client on any platform does not sync hidden files by default.

That is not going to happen.

I am syncing to a web resource.
If that web resource is not in any way abstracting the intricacies of the backend system it is using, as it’s the case here, I should at the very least receive a warning somewhere.
It may be extremely confusing from a UX point to say on a windows app that a “hidden files” feature must be activated to sync files that are only considered hidden from a linux PoV but that’s what’s happening here.