OwnCloud with siteground

Hi, I’m trying to install OwnCloud server 10.3.1 on my siteground’s web hosting.
I dowloaded the tarball, copied on my server and extracted the package. I created the MySql database and the user and started the installation that completed successfully.
Now when I go to the owncloud page I see the login page but when I compile the form with the administrator’s username and password nothing will happen. It stucks on the login page either pressing enter or the right arrow icon. I don’t receive any kind of error.
Anyone can suggest me a solution?


how about filling in the template so we have more informations to better help you ?
Do you have a shell access ?

1 Like

Hi cs35, thank you for the reply. Yes, I can activate SSH access from c-panel. Sorry, now I can’t see the template anymore. The web address where I installed owncloud is

Hi casper,

you’re welcome ! I wouldn’t give the address of the real installation but you do as you prefer for yourself.
So anyway, could you increase the log verbosity of ownCloud ? Then check your logs after testing again to log in.

Could you SSH to your server and do this command to dump all your config and post it here:

sudo -u www-data php  occ config:list

It should hide the sensitive data, but please check before to post.

1 Like

Hi cs35, I tried to compile either the template or to reply to your post but actually I have some problem accessing via ssh to my siteground account. Maybe there is a little mistake in the how to guide. I will access when I am at home in the weekend and I try to reply as well as I can. Thank you :slight_smile:


no problem ! Have a nice day.

Now I have the access via SSH but the server doesn’t allow me to execute that command. I think “sudo” isn’t enabled and I can’t enable using usermod… The siteground’s operating system is CentOS. Have a nice day you too :slight_smile:

You could just try to run occ without sudo. I haven’t touched a cPanel installation in quite some time, but I think in certain configurations you’re logging in as the user that is also running PHP in apache.


I tried to put only occ config:list but it doesn’t work :frowning:

Have you tried running it with or without php in front?

Like @cs35 said earlier, have you tried looking in the logs and increasing the verbosity?
Also look in the apache and php logs.

Make sure that all required PHP modules are installed and enabled. https://doc.owncloud.com/server/admin_manual/installation/manual_installation.html#php-extensions

The bug your experiencing sounds like it might be a session issue, make sure that you can write the session folder.

Also double check the enabled PHP version.

1 Like

I checked PHP version and changed to 7.2.34 as suggested by the guide but it doesn’t work.
Now I take a lot of time to try to understand what to do. I’m not on a normal linux build but I can use only c-panel or the ssh with few commands available. I need to understand how to check all the requirements in this system.

I can’t find it, I’m very limited, it’s a shared host, the folder structure is different from any linux installation, I can see only a part of the whole system’s folder tree. I can’t work like a local linux machine.