Owncloud X oauth2 Dropbox V2 external storage stays empty only syncing newly added files to Dropbox

oauth2
external_storage
10

#1

Dear all,

after upgrading to owncloud X and the newest app for Dropbox (https://github.com/owncloud/files_external_dropbox/) I tried to readd my dropbox as oauth2 external storage (https://owncloud.org/blog/external-storage-dropbox/).

The tutorial was good so far and dropbox got connected via the api v2 (oauth2).

Unfortunately either the App or the oauth behaves a little strange. Right after dropbox became visible as external storage, I browsed it and received the message that "nothing is in here".

Well okay. So I tried adding a new File to this external Storage and had success. The new file was uploaded quite nice and even synced to my dropbox account! So the file, added via owncloud became visible in my dropbox account.

I'm a little disappointed about the fact that I can not use my files in my dropbox, that are already existing to make them visible in my owncloud-folder of the external storage.

Bug or feature?

Cheers,
H0rst


#2