ownCloud10 - external storage GoogleDrive - Grant Access button no response


#1

I have created my app successfully on Google. I add the client ID & the Client secret. After I click on Grant Access, nothing happens. (This used to work in the past. I have already been able to setup my connection to GoogleDrive) The authorization page should be displayed, but nothing happens. I thought it had to do with the browser settings, I verified that pop-up windows are allowed, then I switched the browser, and nothing. I tried it with Dropbox in order to see if this only happens with GoogleDrive but the same happens with Dropbox. How can I correct this faulty behavior?


#2

Hi,

could you provide a screen shot of the error?


#3

Hi, I have exactly the same issue. When I click on Grant Access, button still disable and I have no redirect to google service.

Here my screenshot

There is nothing in the log or in the console.


#4

Please check the browser's network console. You might want to try with ownCloud 10.0.5 RC3 as it fixes some issues with the JS code related to oauth.


#5

This issue is fixed in the next ownCloud release.

You can wait until the next release or patch your installation with this patch:

or this way:

https://patch-diff.githubusercontent.com/raw/owncloud/core/pull/30071.patch


#6

Thank you very much for the response and the patch. I changed the code manually. I suppose that was not the best method. I still cannot add any external cloud and additionally I have the following error in the console:

How can I solve this?


#7

Patch doesn't solve my problem either. I've observed that when I add the Gdrive mount, I have a weird error :

POST https:/********/index.php/apps/files_external/userstorages 422 (Unprocessable Entity)

When I click on the Grant access button, nothing append and when I refresh the page, the mount disappears.


#8

To complete, I tried with a new installation with docker and sometimes this exact problem occurs (but sometimes it works).


#9

I have upgraded to version 10.0.7 and I still cannot add any external cloud storages.

Please help!!!


#10

any or the one from this topic?

I have tested it right now, and could integrate my Google drive API in to my owncloud. The documentation was a bit rough though.


#11

It still didn't work for me.

My Workaround: Reinstalled ownCloud 9.1.8 and could add Google Drive to my Server. Next I upgraded to ownCloud 10.0.7 and kept Google Drive installed.


#12

I have the same or at least very similar problem. I have owncloud 10.0.7.2 installed, dropbox as external storage works nicely with oauth2, but can´t add Google Drive as external storage, always a red rectangle and no oauth consent page redirect.

Before updating I could add the Google Drive to my Server, but had some issues with already deleted folders from Google drive. Removing the external storage and recreate the mount point does not work, as I can not authenticate now. I removed all tokens, cookies, session information to retry from fresh.

I continuously receive "POST https://example.com/owncloud/index.php/apps/files_external/globalstorages 422 (Unprocessable Entity)". In the Network tab I just find the reply "{message: "Unsatisfied authentication mechanism parameters"}", even though client id and secret, authentication is all provided.

Any ideas?


#13

Any help on this ?
I can get dropbox working no problems.
i can get 1 googledrive working no problem.
i can't get a second googledrive working is there a limit on how many you can link?


#14

This is exactly what’s happening to me with the current version of ownCloud and https://doc.owncloud.org/server/latest/admin_manual/configuration/files/external_storage/google.html is extremely dated… wasn’t easy to follow with all the UI changes at console.developers.google.com

Any solution to this yet?


#15

I too have this issue. I’ve tried all sorts of ways but no go (disable pop-up blocker, adblocker, recreate creds, enable/disable API, etc) but consent screen never pops up. Running ownCloud 10.0.9 in Docker on Linux.

Chrome Inspector, Network tab:
{message: “Unsatisfied authentication mechanism parameters”}
message: “Unsatisfied authentication mechanism parameters”
in Globalstorages

And in Console Tab:
POST https://xxxxx.com/apps/files_external/globalstorages 422 (Unprocessable Entity)

send @ jquery.min.js?v=cfd4ed067d6431387287415762634517:4
ajax @ jquery.min.js?v=cfd4ed067d6431387287415762634517:4
save @ settings.js?v=cfd4ed067d6431387287415762634517:277
saveStorageConfig @ settings.js?v=cfd4ed067d6431387287415762634517:1182
(anonymous) @ settings.js?v=cfd4ed067d6431387287415762634517:747
setTimeout (async)
_onChange @ settings.js?v=cfd4ed067d6431387287415762634517:746
dispatch @ jquery.min.js?v=cfd4ed067d6431387287415762634517:3
r.handle @ jquery.min.js?v=cfd4ed067d6431387287415762634517:3


#16

Hi, same here, doesn’t work in OwnCloud 10.0.10.4.
It does work with Nextcloud 14 (installed on the same, hosted server, of course in an other directory), maybe this is a helpful information.

The “Grant Access”-Button turns grey, but nothing else happens.

The “workaround” posted from helpneeded in post #11 works, but that isn’t really a solution

Is anybody working on this issue?


#17

I’ve the same issue right now. Checked the code changes of the mentioned github-patch. Is there already a real solution, beside reinstalling an old version?

I’m using owncloud-Version: 10.1.0.4


#18

I have the same issue. I’m using owncloud 10.1.0