Owncloudcmd.exe on MSWindows10

Hello good Morning!
My name is Marcelo and I need help with the owncloudcmd.exe utility.
I run as per the syntax “owncloudcmd.exe -u user -p password source destination” but I get the error below.

owncloudcmd.exe -u myusetest -p mypasswordtest c:\temp http://mysrv.ddns:8081/owncloud/remote.php/dav/files/myusetest/doc
09-09 10:36:39:887 [ warning sync.networkjob.jsonapi ]: Network error: “ocs/v1.php/cloud/capabilities” “Server replied “404 Not Found” to “GET http://mysrv.ddns:8081/owncloud/remote.php/dav/files/myusetest/doc/ocs/v1.php/cloud/capabilities?format=json”” QVariant(int, 404)
09-09 10:36:39:889 [ debug default ] [ main::::operator() ]: Server capabilities QJsonObject()
Error connecting to server

could someone help in the resolution?
any help would be very welcome, thanks in advance

Server configuration

UBUNTU 20.04.2
APACHE
MYSQL
OWNCLOUD X

#OWNCLOUD CLIENT
2.8.24246

I think it should look like this:

owncloudcmd.exe -u myusetest -p mypasswordtest c:\temp http://mysrv.ddns:8081/

I tested this on macOS:

/Applications/owncloud.app/Contents/MacOS/owncloudcmd -u demo -p demo ~/tmp-sync https://demo.owncloud.com/

To only sync a subfolder “/Photos” from the account, this worked too:

/Applications/owncloud.app/Contents/MacOS/owncloudcmd -u demo -p demo ~/tmp-sync2 https://demo.owncloud.com/remote.php/webdav/Photos

Here you can find more information:
The Command Line Client :: ownCloud Documentation

1 Like

Hello Michael!
I’m here to thank you so much for your support. With your example I could see where I was going wrong and managed to sync via owncloudcmd.exe. Now I can get on with my tests with the task scheduler!
Thank you very much!