Owncloudcmd has to run X amount of times to sync the directory

9.0.x
help

#1

Please help us by providing the following info. Before posting please make sure that you're running the latest available version for your oC release: https://owncloud.org/changelog/ + https://owncloud.org/changelog/desktop/

Steps to reproduce
1. owncloudcmd -h . https://foo:bar@hukarz/remote.php/webdav/
2. run it again, cause it didn't grab everything the first time
3. run it again, cause it didn't grab everything the second time
4. run it again and again and again and each time, it grabs more data

Expected behaviour
Tell us what should happen
It should only be run once.

Actual behaviour
Tell us what happens instead
I have to run it many times to grab all the data and I'm not even sure I have everything

Client configuration
Client version: 2.3.1
Client operating system: Ubuntu GNU/Linux 16.04

Server configuration
Operating system: Hosted
Web server:
Database:
PHP version:
ownCloud version (see ownCloud admin page):
Updated from an older ownCloud or fresh install:
Special configurations (external storage, external authentication, reverse proxy, server-side-encryption):

ownCloud log (data/owncloud.log)

Please paste possible errors in the following code block, see https://central.owncloud.org/t/how-to-find-webserver-or-oc-logfile-enable-php-logfile/808 for more info


#2

IMHO nothing what can be done from user-side here (the forums is user-based support) so please report such issues directly to the sync client developers at https://github.com/owncloud/client/issues if this is not the expected behaviour.


#3

well, I though I'd post it in here, first, to see if this was normal behavior


#4

Linking https://github.com/owncloud/client/issues/5704