Owncloudcmd linux client is ignoring files from fed.share

Hi all

I have several owncloud servers running version 10.0.10.4 (not possible to update right now to new version). From first server I have share of folder via federation to each other server. This is working. First issue is delay approx 5 minutes between creating file on first server and see it on others.
Second is bigger. From each server I am using owncloud command line linux client where I am syncing folder form fed . share. First share ( after setting up) was successful. Next tests were not successful.

When I create file on first one, FED share will sync it to other server, but clients are ignoring this file. File is not synced to the end.

Expected behaviour

Fed share should be synced to another servers in at last one minute.
All files from FED share should be synced via owncloudcmd

Actual behaviour

Federated share took more than 5 minutes to sync files from one server to others.
First sync of files via owncloudcmd from federates share is success, other test files are ignored by owncloudcmd

Server configuration

Operating system: SUSE Linux Enterprise Server 12 SP5

Web server: Apache Webserver 2.4.23

Database: 10.2.25-MariaDB

PHP version: 7.0.7

ownCloud version: server 10.0.10.4

Storage backend (external storage): no

Client configuration

Client version: 2.6.1 (Linux)

Operating system: openSUSE Leap 15.2

OS language:EN

Qt version used by client package (Linux only, see also Settings dialog): should be v5

Client package (From ownCloud or distro) (Linux only): from repository

Installation path of client: default

Thanks for any kind of help

Server is probably too slow to propagate those changes. There are improvements in the later versions. As a workaround you need to schedule occ files:scan of this folders with cron. (every minute or so in your case)
https://doc.owncloud.com/server/admin_manual/configuration/server/occ_command.html#file-operations

Thank you
but unfortunately it is scanning only for local files not for federated files

I found out that if owncloudcmd client is not syncing new files, I will shut it down then I delete his sqlite3 db (._sync_1xxxxxxxxxx.db) then start again. Then I see all files synced.

FYI normally I am using command COMMAND="/usr/bin/owncloudcmd -n /usr2/transfer/owncloud/ https://serveraddress/owncloud"

I tested also
COMMAND="/usr/bin/owncloudcmd -n --max-sync-retries 6 --non-interactive --trust /usr2/transfer/owncloud/ https://serveraddress/owncloud"

but situation is the same

The root cause is on the server, not the client.

Initial discovery crawls through all folders. This also happens again after you deleted the sync journal.

Later sync runs normally only check for changes. For this it checks the ETag of the root folder. ownCloud server should propagate ETag changes from subfolders back to the root folder. This is not working reliably with the old server version you’re running.

2 Likes

yes, you are right.

I found article about incoming shares poll
probably from server version 10.2 there is available"occ incoming-shares:poll" which is updating FED shares and then it is working
from 10.5 version this command is deprecated and replaced by background job