Password not found (Ubuntu 18.04 LTS and Buster) 2.6.0+oc-1714

With the most recent updates of owncloud client in combination with Ubuntu 18.04 LTS respectivly Debian Buster, the client doesn’t hav access to the keychain.

The user has to input the password after restart of the system (and maybe after logging off an on)

Expected behaviour

Tell us what should happen

start oc-client without asking for password

Actual behaviour

Tell us what happens instead

oc-client asks for password

Steps to reproduce

  1. power on the pc. Log in to an account with oc-synchronisation.
  2. A popup asking for the password appears

Client configuration

Client version:

2.6.0+oc-1714
Operating system: Ubuntu 18.04 LTS and Buster

OS language:
German

Qt version used by client package (Linux only, see also Settings dialog):

Client package (From ownCloud or distro) (Linux only):

From http://download.opensuse.org/repositories/isv:/ownCloud:/desktop/

Hey,

this looks to me like a duplicate thread of the following:

I tried to
-uninstall oc 2.6.
-remove the opensuse/ubuntu-repository
-install the orginal ubuntu-package 2.4.1+dfsg-1

All with the graphical interface.
The result is that owncloud doesn’t even start.

I hope the will be a fixed package soon…

Here is the log of the command “owncloud” entered in the terminal.

12-01 20:13:29:761 [ info gui.application ]: “################## ownCloud locale:[de_DE] ui_lang:[] version:[2.4.1] os:[Ubuntu 18.04.3 LTS]”
12-01 20:13:29:761 [ info gui.application ]: Using “de_DE” translation
12-01 20:13:29:761 [ info gui.application ]: Loading global exclude list
12-01 20:13:29:762 [ info gui.socketapi ]: server started, listening at “/run/user/1000/ownCloud/socket”
12-01 20:13:29:762 [ info gui.folder.manager ]: setting remote poll timer interval to 30000 msec
12-01 20:13:29:781 [ info gui.account.manager ]: Account for QUrl(“https://xxxxxxxxx”) using auth type “http”
12-01 20:13:29:782 [ info gui.folder.manager ]: Setup folders from settings file
12-01 20:13:29:782 [ info gui.folder ]: Adding system ignore list to csync: “/etc/owncloud-client/sync-exclude.lst”
12-01 20:13:29:782 [ info gui.folder.manager ]: Adding folder to Folder Map OCC::Folder(0x55c34e6ff960) “1”
12-01 20:13:29:782 [ info gui.folder.manager ]: Schedule folder “1” to sync!
12-01 20:13:29:782 [ info gui.folder.manager ]: Folder is not ready to sync, not scheduled!
12-01 20:13:29:782 [ info sync.clientproxy ]: Set proxy configuration to use system configuration
12-01 20:13:29:803 [ info sync.database ]: sqlite3 version “3.22.0”
12-01 20:13:29:803 [ info sync.database ]: sqlite3 journal_mode= “wal”
12-01 20:13:29:803 [ warning sync.database.sql ]: Sqlite prepare statement:

Hey,

i’m not sure but if a fix is required then i think a bugreport is required first.

From what i know / have read in the past the ownCloud people are working only with the github bugtrackers, the one for the Desktop client seems to be available at https://github.com/owncloud/client/issues where you would need to create a bugreport to get a possible fix afterwards (if the ownCloud people are able to confirm a problem).

I posted it on github…

2 Likes

Hey,

i think this is great. Could you post a link to this github report so other users are able to find it more easily?

1 Like

I’ve installed the two packages
libgnome-keyring0 and
libgnome-keyring-common
on Ubuntu 18.04 LTS
in addidtion to the already installed libgnome-keyring.

This solves the problem for Ubuntu 18.04.

I didn’t find a solution for Debian/Buster.