Xubuntu Keychain error

Expected behaviour

After configuration, the client should work in the background with no further input required.

Actual behaviour

Every time after logging in, the client asks for the password. This used to happen (almost) every time I would install owncloud on a fresh xubuntu installation, however there used to be a workaround by installing libqtkeychain0. Unfortunately, this package does no longer get maintained, and therefore is not available for install on the 19.10 ubuntu repos anymore.

I have tried activating the Gnome Services in the xfce menu. Also, other programs accessing the keychain work flawlessly (e.g. evolution mail client)

Interestingly, with other desktop environments (I tried Ubuntu Budgie 19.10), this did not occur.

Steps to reproduce

  1. Install Xubuntu 19.10
  2. Connect your account
  3. Log off and on again (or reboot)

Server configuration (I dont think this is a server problem but anyway)

Operating system: Ubuntu Server 18.04

Web server: Apache 2.4.29

Database: MySql 5.7

PHP version: 7.2

ownCloud version: 10.0.3.4

Storage backend (external storage):

Client configuration

Client version: 2.6

Operating system: Xubuntu 19.10

OS language: English, but with german regionale

Qt version used by client package (Linux only, see also Settings dialog): 5.12.5

Client package (From ownCloud or distro) (Linux only): From Owncloud Repository

Installation path of client: I’m not sure how to check that, but I asume the default path as I installed it via apt without any further parameters

Logs

Please use Gist (https://gist.github.com/) or a similar code paster for longer
logs.

Template for output < 10 lines

  1. Client logfile: Output of owncloud --logwindow or owncloud --logfile log.txt
    (On Windows using cmd.exe, you might need to first cd into the ownCloud directory)
    (See also http://doc.owncloud.org/desktop/2.2/troubleshooting.html#client-logfile )

https://pastebin.com/8DrtErfs

  1. Web server error log:

  2. Server logfile: ownCloud log (data/owncloud.log):

Hey,

maybe these discussions are related?

If i remember correctly i had seen also various reports to the ownCloud team around such topics at https://github.com/owncloud/client/issues. I wasn’t able to find them on a short search but maybe you have better luck?

Hi Tom,

thanks for answering. Unfortunately, there also is no libgnome-keyring on the ubuntu 19.10 repositories anymore…

However, I had a look on github, as you suggested, and found, as a temporary solution, to disable the owncloud repository and use the sync client from the ubuntu repositories (2.6 vs 2.5.1).

In my search, I also installed seahorse which allows me to have a look on the stored keyrings. Before I uninstalled the client from the owncloud repository, there was no owncloud-key stored in my keyring. But after installing the client from the ubuntu repository and reconfiguring my account, there was an entry in my keyring and everything works.

Is the owncloud-client from the ubuntu repos (apart from the different version) the same as the client from the owncloud repository? Ie. does it work now because I am on an older version, or because the ubuntu devs changed something in the client distributed through the ubuntu repositry?

1 Like

On Ubuntu 18.04 LTS I tried to
-uninstall oc 2.6.
-remove the opensuse/ubuntu-repository
-install the orginal ubuntu-package 2.4.1+dfsg-1

All with the graphical interface.
The result is that owncloud doesn’t even start.

Any ideas why this doesnt work?

@Der_Anwender found a possible existing bugreport to the ownCloud dev team:

1 Like