Pause sync on metered connections

Hello,

I was using my phone as access point yesterday and was surprised that owncloud ate almost 1GB of my data plan. When connecting I did get a notification from onedrive that syncing was paused because a metered connection was detected, but apparently owncloud does not have this functionality.
Is this correct?

Since I will be working in the train a lot in the future, it would be very inconvenient if I have to pause/unpause syncing manually.

Best regards,
Paul

Expected behaviour

pause syncing when a metered network connection is detected

Actual behaviour

owncloud treats all network connections the same

Client configuration

Client version: 2.8.2

Operating system: Windows 10

OS language: en

Feature not implemented yet.

It was previously discussed here:
Don't sync when device is on cellular/mobile connection · Issue #4808 · owncloud/client · GitHub

One recommendation was https://www.tripmode.ch/ there.

Hi,
Thanks, that didn’t show up when searching for ‘metered’.
Anyway, tripmode for windows is no longer supported, so that’s not a serious option.
Alternatives (TripMode Alternatives and Similar Software | AlternativeTo) are not widely available for windows, with the exception of zonealarm. I doubt if that’s going to behave next to symantec endpoint protection which is already installed. (can not replace that, company policy)
It seems to me that there are no good alternatives.

Best regards,
Paul