Pdf is not syncing with owncloud windows client

webserver_issue
help

#1

Please help us by providing the following info. Before posting please make sure that you're running the latest available version for your oC release:

Steps to reproduce
1. I dropped a doc and a pdf file in windows folder to be sync by client
2. after a while then I got the red mark symbol on pdf file not able to sync, but doc file was syncing properly

Expected behaviour
above stated

Actual behaviour
Tell us what happens instead
above stated

Client configuration
Client version: 5.6.2
Client operating system: win7

Server configuration
Operating system: CENTOS 7.3 x86_64 standard
Web server:
Database: MySQL
PHP version: 5.6
ownCloud version (see ownCloud admin page):
Updated from an older ownCloud or fresh install:
Special configurations (external storage, external authentication, reverse proxy, server-side-encryption):

ownCloud log (data/owncloud.log)
As I am not able to upload more than 2 URL and logfile is too big, I have established to open the log files by onedrive

Client log file

Client log file > https://1drv.ms/u/s!Ar74zfbWvJLIhHyO19WgdttzEn7K

Please paste possible errors in the following code block, see https://central.owncloud.org/t/how-to-find-webserver-or-oc-logfile-enable-php-logfile/808 for more info

server log file is here > https://1drv.ms/u/s!Ar74zfbWvJLIhH2AzLq6VyqqO7Yx

#2

Your server logs stop before you have the error in your client:

FINISHED WITH STATUS QNetworkReply::NetworkError(ContentOperationNotPermittedError) "Error transferring

It was at 14h39 (CET?) and your server log finishes at 12h36 GMT. I'm not sure if there is a server error at all. Could also be that the files is locked or something like that. Is it just that file, or do pdf files not work in general?

It might be worth cheking if your SELinux is blocking something (if enabled) or other filtering software like mod_security.


#3

Hi again,

we have tried "SELinux" is inactive and deactivated also "mod_security", but still having issues
to transfer the files from client to server.
Screen Shot > https://www.screencast.com/t/zZdddaDbF

There seems again to be a server setting which may not alow the pdf,rtf file uploads.
Looking forward to your suggestions.

BR, Alex


#4

Setup a plain Debian stable with ownCloud 9.1.5 which doesn't show this issue and then compare this setup with your current installation / operating system might help you here to understand this problem.


#5

Hi kljhlkhglklfgh,

unfortunately therefore I need then to buy a new test server to establish all necessary which is not possible at the moment.

Please try to suggest an other solution to solve my problem of pdf and other docs i.e. rft does not sync with server via client.

BR, Alex


#6

you can easily set up a virtual machine, there is no need to buy new hardware for such tests.

ownCloud itself doesn't block pdf files, with virtual machine images (https://owncloud.org/install/#edition) you could find out if it is related to your server operating system or other network devices (client-side, firewall, proxy, ...).


#7

This is the only suggestion which can be given here:

Compare a working environment with your non working environment to find the curlprint why your enviornment is showing this issue.


#8

Hi support team,

I again tried to find out the issue by deactivating the firewall settings on server, but without success.
Please find again the client log file may helpful to see which problem may exists to take care for.

2017-04-24_owncloud-Failure_client-log-file > https://1drv.ms/u/s!Ar74zfbWvJLIhH5igNZUhB9nzsF3

BR, Alex


#9

Hi All togther,

I still need help because not able to do a debian installation on my existing server.
May the last client log file will help to sort out the issue.

2017-04-24_owncloud-Failure_client-log-file > https://1drv.ms/u/s!Ar74zfbWvJLIhH5igNZUhB9nzsF3

Please check and let me know your suggestions.

BR, Alex


#10

"Doc Validation TEST.pdf - server replied: Not Allowed" QVariant(int, 405) QVariant(QString, "Not Allowed")\par"
Please test against demo.owncloud.org to see if it works there - quite sure it will.
Which means the challenge is in the Linux/infrastructure side, somewhere.
If you rename to something non -pdf does it work then?


#11

Hi again,

we could solve the issue now. We are using Nginx on our server with special firewall protetion. We tweaked those now and it is working.

Thank you very much for poiting us in right direction.

BR, Alex