Permission error on data mount of 10.0.2 DOCKER


#1

Hello, on ubuntu 16.04 we created a owncloud docker, that refuses to use the mounted data directory.
Whereas the mount already has this permissions:

drwxrwx---+ 1 www-data www-data 0 Jul 11 22:58 oc-serstore/

The docker-owncloud log shows some "permission denied".
So I tried some variations of mounting without further success.
Supposingly the docker-oc tries to chown the already owned directories, since this attempt also fails on shell (engl. below):

root@machine16:/mnt/oc-serstore# chown www-data:realusername test
chown: der Eigentümer von 'test' wird geändert: Keine Berechtigung 
(engl: owner of "test" is being changed: permission denied)

We already tried this and other mounting options and variations:
Permission denied when uploading a file to newly created shared folder

Do you guys have any idea on how to make oc-docker accept the data?


#2

Are you using the official docker files? https://hub.docker.com/r/owncloud/server/
They might also give a good hint ...


#3

Yes, it's the "original" docker image.
Running on ubuntu 16.04 server mounting to ubuntu 14.04 server