Permissions problem

Guys,
I had some problems overy my PHP version on my server. I have set 7.2 for every virtual server that i have and that made owncloud to work.
I used a web update and it crashed somehow after some time leaving me with message on logon saying that permissions are not correct. So i’ve decided to use the script from the website which made it even worse. Now I am getting “File not found” and that’s it. After working with the correct links in the script I get the below.

Can you help me sort this out? I’m 2 seconds from setting up nextcloud on docker.

Here is the main dir:


Dont bash on doing shit on root - I know :wink:

Operating system: Ubuntu 18.04

Web server: apache2 build with Virtualmin and Webmin

Database: MySQL

PHP version: 7.2

ownCloud version: 10

Updated from an older ownCloud or fresh install: fresh

Where did you install ownCloud from: webpage

Signing status (ownCloud 9.0 and above):

Login as admin user into your ownCloud and access 
http://example.com/index.php/settings/integrity/failed 
paste the results into https://gist.github.com/ and puth the link here.

Cannot be done

The content of config/config.php:

Log in to the web-UI with an administrator account and click on
'admin' -> 'Generate Config Report' -> 'Download ownCloud config report'
This report includes the config.php settings, the list of activated apps
and other details in a well sanitized form.

Cannot be done

or 

If you have access to your command line run e.g.:
sudo -u www-data php occ config:list system
from within your ownCloud installation folder

Check screenshot.

Can you paste a link to the script?

What do you mean by correct links?

If you have the wrong filepermissions neither docker nor nextcloud will help you…

The error message is very clear in the second screenshot you posted:

Your data directory is not writable by ownCloud.

If you look at the permissions of your data folder in the third screenshot:

drwxr-x---  2 root www-data    4096 Jun 12 02:08  data

As the folder is owned by root and only the user has write permissions apache can’t write to that directory.
I would recommend to chown it to the www-data user.

1 Like

ok so for everyone for future reference. I’ve fixed it.

In some kind of a mess I’ve changed PHP server from mod_php in Apache to FPM. That fixed it :slight_smile:

1 Like

Just FYI: FPM is not officially supported as there might be some problems around ‘thread safety’. However there are some users also here in the forum who run it successfully.