PFS is not supported what shoud i do?

I checked the owncloud server through Appscan and found that PFS(Perfect Forward Secrecy) is not available
After a closer look, the following causes came out

“The server is using a weak cryptographic suite”

What should I do to solve these problems? Should I update the owncloud?

my owncloud version = 10.10.0 (stable)
ssl = TLS 1.2

Hey,

i don’t think that this question is related to ownCloud and i think that it should be placed in an adequate support forum for the web server in use because:

enabling e.g. FPS ciphers needs to be done on web server level

i think there are more enough guides available on the internet on correct TLS configurations of most common web servers (for example https://ssl-config.mozilla.org/)

2 Likes