PHP 7.4 is EOL. FreeBSD will remove it soon

PHP has EOLd version 7.4. FreeBSD will soon remove it from the ports tree.

Steps to reproduce

Upgrade PHP to 8.1

Expected behaviour

ownCloud installs

Actual behaviour

ownCloud fails to install - unsupported

Server configuration

Operating system: FreeBSD 13.1-p4

Web server:
Apache 2.4.54

Database:
MySQL 5.7

PHP version:
8.1

ownCloud version: (see ownCloud admin page)
10.11.0.6

Updated from an older ownCloud or fresh install:
updated

Where did you install ownCloud from:
FreeBSD ports

Hello,

sadly you cannot use a PHP version higher than 7.4, there are several threads around about PHP 7.4 being EOL, but you can read this one to have a “fix” …
Cheers.

Thanks for the link! A search didn’t find that.

Time to migrate to nextCloud.

P.S.: I’ll drop maintainership of the MacPorts port of own cloud-client, as I’ll no longer use it myself.